summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 18:30:19 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:05 +0000
commit617a60f51942e159ae0f40f0e47f9cf8e45e9ffb (patch)
tree01c8fb9073413a232502ab993c1c536e56778ce1 /dev-haskell/doctest/doctest-0.20.0.ebuild
parentdev-haskell/doctemplates: add 0.10.0.2 (diff)
downloadgentoo-617a60f51942e159ae0f40f0e47f9cf8e45e9ffb.tar.gz
gentoo-617a60f51942e159ae0f40f0e47f9cf8e45e9ffb.tar.bz2
gentoo-617a60f51942e159ae0f40f0e47f9cf8e45e9ffb.zip
dev-haskell/doctest: add 0.20.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/doctest/doctest-0.20.0.ebuild')
-rw-r--r--dev-haskell/doctest/doctest-0.20.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/doctest/doctest-0.20.0.ebuild b/dev-haskell/doctest/doctest-0.20.0.ebuild
new file mode 100644
index 000000000000..def4fb91b388
--- /dev/null
+++ b/dev-haskell/doctest/doctest-0.20.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+inherit haskell-cabal
+
+# Buggy tests
+# May be related: <https://github.com/sol/doctest/pull/135>
+RESTRICT="test"
+
+DESCRIPTION="Test interactive Haskell examples"
+HOMEPAGE="https://github.com/sol/doctest#readme"
+HACKAGE_REV="5"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/base-compat-0.7.0:=[profile?]
+ >=dev-haskell/code-page-0.1:=[profile?]
+ >=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
+ >=dev-haskell/syb-0.3:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0"
+# test? ( >=dev-haskell/hspec-2.3.0
+# >=dev-haskell/hspec-core-2.3.0
+# dev-haskell/hunit
+# dev-haskell/mockery
+# >=dev-haskell/quickcheck-2.13.1
+# dev-haskell/setenv
+# >=dev-haskell/silently-1.2.4
+# >=dev-haskell/stringbuilder-0.4 )
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}