summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/higan-ananke/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/higan-ananke/files')
-rw-r--r--dev-games/higan-ananke/files/higan-ananke-092-bps-path-fix.patch11
-rw-r--r--dev-games/higan-ananke/files/higan-ananke-092-makefile.patch20
-rw-r--r--dev-games/higan-ananke/files/higan-ananke-094-makefile.patch38
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-games/higan-ananke/files/higan-ananke-092-bps-path-fix.patch b/dev-games/higan-ananke/files/higan-ananke-092-bps-path-fix.patch
new file mode 100644
index 000000000000..e951f645aa78
--- /dev/null
+++ b/dev-games/higan-ananke/files/higan-ananke-092-bps-path-fix.patch
@@ -0,0 +1,11 @@
+diff --git a/ananke/patch.cpp b/ananke/patch.cpp
+index a2dc1f9..6692800 100755
+--- a/ananke/patch.cpp
++++ b/ananke/patch.cpp
+@@ -1,5 +1,5 @@
+ void Ananke::applyBeatPatch(vector<uint8_t> &buffer) {
+- string name = {nall::basename(information.name), ".bps"};
++ string name = {information.path, nall::basename(information.name), ".bps"};
+ if(!file::exists(name)) return;
+
+ bpspatch patch;
diff --git a/dev-games/higan-ananke/files/higan-ananke-092-makefile.patch b/dev-games/higan-ananke/files/higan-ananke-092-makefile.patch
new file mode 100644
index 000000000000..2562ffec9ea4
--- /dev/null
+++ b/dev-games/higan-ananke/files/higan-ananke-092-makefile.patch
@@ -0,0 +1,20 @@
+--- higan_v092-source/ananke/Makefile
++++ higan_v092-source/ananke/Makefile
+@@ -2,7 +2,7 @@
+ include phoenix/Makefile
+
+ path := /usr/local/lib
+-flags := -I. -O3 -fomit-frame-pointer
++flags := -I. $(CXXFLAGS)
+ ifeq ($(arch),win32)
+ flags := -m32 $(flags)
+ endif
+@@ -10,7 +10,7 @@
+ all:
+ $(cpp) $(flags) -fPIC -o ananke.o -c ananke.cpp
+ ifeq ($(platform),x)
+- $(cpp) $(flags) -shared -Wl,-soname,libananke.so.1 -o libananke.so ananke.o
++ $(cpp) $(flags) $(LDFLAGS) -shared -Wl,-soname,libananke.so.1 -o libananke.so ananke.o
+ else ifeq ($(platform),win)
+ $(cpp) $(flags) -fPIC -o phoenix.o -c phoenix/phoenix.cpp $(phoenixflags)
+ $(cpp) $(flags) -shared -o phoenix.dll phoenix.o $(phoenixlink)
diff --git a/dev-games/higan-ananke/files/higan-ananke-094-makefile.patch b/dev-games/higan-ananke/files/higan-ananke-094-makefile.patch
new file mode 100644
index 000000000000..14639614cad7
--- /dev/null
+++ b/dev-games/higan-ananke/files/higan-ananke-094-makefile.patch
@@ -0,0 +1,38 @@
+--- a/ananke/Makefile
++++ b/ananke/Makefile
+@@ -2,7 +2,7 @@
+ include ../phoenix/Makefile
+
+ path := /usr/local/lib
+-flags := $(flags) -O3 -fomit-frame-pointer -I..
++flags := $(flags) $(CXXFLAGS) -I..
+
+ all:
+ $(compiler) $(cppflags) $(flags) -fPIC -o obj/ananke.o -c ananke.cpp
+@@ -13,7 +13,7 @@
+ else ifeq ($(platform),macosx)
+ $(compiler) $(link) -shared -dynamiclib -undefined suppress -flat_namespace -o libananke.dylib obj/ananke.o
+ else
+- $(compiler) $(link) -shared -Wl,-soname,libananke.so.1 -o libananke.so obj/ananke.o
++ $(compiler) $(link) $(LDFLAGS) -shared -Wl,-soname,libananke.so.1 -o libananke.so obj/ananke.o
+ endif
+
+ resource: force
+--- a/nall/Makefile
++++ b/nall/Makefile
+@@ -53,11 +53,11 @@
+ link :=
+ endif
+
+- cflags := -x c -std=c99
+- objcflags := -x objective-c -std=c99
+- cppflags := -x c++ -std=c++11
+- objcppflags := -x objective-c++ -std=c++11
+ endif
++cflags := -x c -std=c99
++objcflags := -x objective-c -std=c99
++cppflags := -x c++ -std=c++11
++objcppflags := -x objective-c++ -std=c++11
+
+ # cross-compilation support
+ ifeq ($(arch),x86)