summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/aseprite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/aseprite')
-rw-r--r--dev-games/aseprite/Manifest2
-rw-r--r--dev-games/aseprite/aseprite-0.9.5-r1.ebuild102
-rw-r--r--dev-games/aseprite/aseprite-1.0.6.ebuild76
-rw-r--r--dev-games/aseprite/aseprite-9999.ebuild95
-rw-r--r--dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch38
-rw-r--r--dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch21
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-obinary.patch27
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch11
-rw-r--r--dev-games/aseprite/metadata.xml14
9 files changed, 386 insertions, 0 deletions
diff --git a/dev-games/aseprite/Manifest b/dev-games/aseprite/Manifest
new file mode 100644
index 000000000000..00fdc1697cd7
--- /dev/null
+++ b/dev-games/aseprite/Manifest
@@ -0,0 +1,2 @@
+DIST aseprite-0.9.5.tar.xz 507744 SHA256 81e0360d9d8a32d6c548775dbacdb1520aac94b54c2d9f1327d52f219737f154 SHA512 fc6df942aefea67fd05e1b688209b70a2d5879a1441f61a6e3ee4d72fcdab4e580e1d4d7392fd493e0a46c45401a3eef759aa3efee17450e4c98df7f310b2d00 WHIRLPOOL 060dcf2754827ab3b30dde55cfcecd25e2d88f6e296b45529737e2194f4a9891d171776d10f9c571890efb9766b64080b85dc3d737102d2ac7be9843d27fdaef
+DIST aseprite-1.0.6.tar.gz 3685678 SHA256 449619ee49eaf18c483706c6d2364868085b0f311548bd69e5664fdc0c06e21e SHA512 0189cb6d845ea799f84c17b6456a10341a5ba2a2712bed2c202a711ffe60bb3f2e2eb47bb5702c6326f16a842cd8780c4c1f44ba61111a535b172c34e6f2d327 WHIRLPOOL 4bbf000bf30beafef0003f047f625d4af7e61d51336562ba9192eceb4c72cafbd361bf68ba5fef20b260e74997b679d440d2f9e6386c1ab48c0a6e103577caf2
diff --git a/dev-games/aseprite/aseprite-0.9.5-r1.ebuild b/dev-games/aseprite/aseprite-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..00e9e9b0b188
--- /dev/null
+++ b/dev-games/aseprite/aseprite-0.9.5-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Animated sprite editor & pixel art tool"
+HOMEPAGE="http://www.aseprite.org"
+SRC_URI="http://aseprite.googlecode.com/files/aseprite-${PV}.tar.xz"
+
+LICENSE="GPL-2 FTL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="debug memleak static test"
+
+RDEPEND="dev-libs/tinyxml
+ media-libs/allegro:0[X,png]
+ media-libs/giflib
+ media-libs/libpng:0
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+PATCHES=( "${FILESDIR}"/aseprite-0.9.5-as-needed.patch
+ "${FILESDIR}"/aseprite-0.9.5-underlinking.patch )
+
+DOCS=( docs/quickref.odt
+ docs/files/ase.txt
+ docs/files/fli.txt
+ docs/files/msk.txt
+ docs/files/pic.txt
+ docs/files/picpro.txt )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix to make flag-o-matic work.
+ if use debug ; then
+ sed -i '/-DNDEBUG/d' CMakeLists.txt || die
+ fi
+
+ # Only do a static link with Allegro if the user explicitly wants it.
+ if ! use static ; then
+ sed -i '/-DALLEGRO_STATICLINK/d' CMakeLists.txt || die
+ fi
+
+ # Remove long compiling tests for users with FEATURES="-test",
+ # also removes the gtest dependency from the build.
+ if ! use test ; then
+ sed -i '/^find_unittests/d' src/CMakeLists.txt || die
+ sed -i '/include_directories(.*third_party\/gtest.*)/d' src/CMakeLists.txt || die
+ sed -i '/add_subdirectory(gtest)/d' third_party/CMakeLists.txt || die
+ fi
+
+ # Fix from https://465450.bugs.gentoo.org/attachment.cgi?id=345154
+ # for "error: ‘png_sizeof’ was not declared in this scope".
+ sed -i 's/png_\(sizeof\)/\1/g' src/file/png_format.cpp || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUGMODE -D_DEBUG
+
+ local mycmakeargs
+
+ mycmakeargs=(
+ -DENABLE_UPDATER=OFF
+ -DUSE_SHARED_ALLEGRO4=ON
+ -DUSE_SHARED_CURL=ON
+ -DUSE_SHARED_GIFLIB=ON
+ -DUSE_SHARED_JPEGLIB=ON
+ -DUSE_SHARED_LIBLOADPNG=ON
+ -DUSE_SHARED_LIBPNG=ON
+ -DUSE_SHARED_TINYXML=ON
+ -DUSE_SHARED_ZLIB=ON
+ -DFULLSCREEN_PLATFORM=ON
+ $(cmake-utils_use_enable memleak)
+ $(cmake-utils_use_use static STATIC_LIBC)
+ )
+
+ if use test ; then
+ mycmakeargs+=(
+ -DUSE_SHARED_GTEST=ON
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "Warning: aseprite might not choose the resolution correctly; so, you might need"
+ elog " to change the resolution once using the -resolution WxH[xBPP] argument."
+ elog ""
+ elog " On subsequent runs, aseprite will remember the resolution you have set."
+ elog ""
+ elog " For example: \`aseprite -resolution 1440x900\`"
+}
diff --git a/dev-games/aseprite/aseprite-1.0.6.ebuild b/dev-games/aseprite/aseprite-1.0.6.ebuild
new file mode 100644
index 000000000000..a701677ca1b1
--- /dev/null
+++ b/dev-games/aseprite/aseprite-1.0.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="Animated sprite editor & pixel art tool"
+HOMEPAGE="http://www.aseprite.org"
+SRC_URI="https://github.com/aseprite/aseprite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 FTL"
+SLOT="0"
+# giflib still unkeyworded
+KEYWORDS=""
+
+IUSE="debug memleak"
+
+RDEPEND="dev-libs/tinyxml
+ media-libs/allegro:0[X,png]
+ >=media-libs/giflib-5.0
+ media-libs/libpng:0
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/pixman"
+DEPEND="${RDEPEND}
+ dev-cpp/gtest"
+
+PATCHES=( "${FILESDIR}"/aseprite-0.9.5-underlinking.patch
+ "${FILESDIR}"/${P}-obinary.patch
+ "${FILESDIR}"/${P}-png_sizeof.patch )
+
+DOCS=( docs/files/ase.txt
+ docs/files/fli.txt
+ docs/files/msk.txt
+ docs/files/pic.txt
+ docs/files/picpro.txt
+ README.md )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix to make flag-o-matic work.
+ if use debug ; then
+ sed -i '/-DNDEBUG/d' CMakeLists.txt || die
+ fi
+
+ rm -r third_party/* || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUGMODE -D_DEBUG
+
+ local mycmakeargs=(
+ -DCURL_STATICLIB=OFF
+ -DENABLE_UPDATER=OFF
+ -DFULLSCREEN_PLATFORM=ON
+ -DLIBPIXMAN_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --variable=includedir pixman-1)/pixman-1"
+ -DLIBPIXMAN_LIBRARY="$($(tc-getPKG_CONFIG) --variable=libdir pixman-1)/libpixman-1.so"
+ -DUSE_SHARED_ALLEGRO4=ON
+ -DUSE_SHARED_CURL=ON
+ -DUSE_SHARED_GIFLIB=ON
+ -DUSE_SHARED_GTEST=ON
+ -DUSE_SHARED_JPEGLIB=ON
+ -DUSE_SHARED_LIBLOADPNG=ON
+ -DUSE_SHARED_LIBPNG=ON
+ -DUSE_SHARED_PIXMAN=ON
+ -DUSE_SHARED_TINYXML=ON
+ -DUSE_SHARED_ZLIB=ON
+ $(cmake-utils_use_enable memleak)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-games/aseprite/aseprite-9999.ebuild b/dev-games/aseprite/aseprite-9999.ebuild
new file mode 100644
index 000000000000..56d269378738
--- /dev/null
+++ b/dev-games/aseprite/aseprite-9999.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils flag-o-matic git-2
+
+DESCRIPTION="Animated sprite editor & pixel art tool"
+HOMEPAGE="http://www.aseprite.org"
+EGIT_REPO_URI="git://github.com/dacap/${PN}.git"
+
+LICENSE="GPL-2 FTL"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="debug memleak static test"
+
+RDEPEND="dev-libs/tinyxml
+ media-libs/allegro:0[X,png]
+ media-libs/giflib
+ media-libs/libpng:0
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+DOCS=( docs/quickref.odt
+ docs/files/ase.txt
+ docs/files/fli.txt
+ docs/files/msk.txt
+ docs/files/pic.txt
+ docs/files/picpro.txt )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix to make flag-o-matic work.
+ if use debug ; then
+ sed -i '/-DNDEBUG/d' CMakeLists.txt || die
+ fi
+
+ # Only do a static link with Allegro if the user explicitly wants it.
+ if ! use static ; then
+ sed -i '/-DALLEGRO_STATICLINK/d' CMakeLists.txt || die
+ fi
+
+ # Remove long compiling tests for users with FEATURES="-test",
+ # also removes the gtest dependency from the build.
+ if ! use test ; then
+ sed -i '/^find_unittests/d' src/CMakeLists.txt || die
+ sed -i '/include_directories(.*third_party\/gtest.*)/d' src/CMakeLists.txt || die
+ sed -i '/add_subdirectory(gtest)/d' third_party/CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUGMODE -D_DEBUG
+
+ local mycmakeargs
+
+ mycmakeargs=(
+ -DENABLE_UPDATER=OFF
+ -DUSE_SHARED_ALLEGRO4=ON
+ -DUSE_SHARED_CURL=ON
+ -DUSE_SHARED_GIFLIB=ON
+ -DUSE_SHARED_JPEGLIB=ON
+ -DUSE_SHARED_LIBLOADPNG=ON
+ -DUSE_SHARED_LIBPNG=ON
+ -DUSE_SHARED_TINYXML=ON
+ -DUSE_SHARED_ZLIB=ON
+ -DFULLSCREEN_PLATFORM=ON
+ $(cmake-utils_use_enable memleak)
+ $(cmake-utils_use_use static STATIC_LIBC)
+ )
+
+ if use test ; then
+ mycmakeargs+=(
+ -DUSE_SHARED_GTEST=ON
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "Warning: aseprite might not choose the resolution correctly; so, you might need"
+ elog " to change the resolution once using the -resolution WxH[xBPP] argument."
+ elog ""
+ elog " On subsequent runs, aseprite will remember the resolution you have set."
+ elog ""
+ elog " For example: \`aseprite -resolution 1440x900\`"
+}
diff --git a/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch b/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch
new file mode 100644
index 000000000000..9f50c25979ba
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch
@@ -0,0 +1,38 @@
+Description: fix FTBFS with --as-needed linker option
+ Libraries must be placed after object files in command line.
+Author: Ilya Barygin <randomaction@ubuntu.com>
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -135,6 +135,10 @@
+ # All libraries for .exe files
+ set(all_libs ${aseprite_libraries} ${libs3rdparty} ${sys_libs})
+
++if(LIBALLEGRO4_LINK_FLAGS)
++ set(all_libs ${all_libs} ${LIBALLEGRO4_LINK_FLAGS})
++endif()
++
+ ######################################################################
+ # ASEPRITE libraries
+
+@@ -405,10 +409,6 @@
+
+ add_executable(aseprite WIN32 main.cpp ${win32_resources} ${x11_resources})
+ target_link_libraries(aseprite ${all_libs})
+-if(LIBALLEGRO4_LINK_FLAGS)
+- set_target_properties(aseprite
+- PROPERTIES LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS})
+-endif()
+
+ install(TARGETS aseprite
+ RUNTIME DESTINATION bin)
+@@ -450,8 +450,7 @@
+ endif()
+
+ if(LIBALLEGRO4_LINK_FLAGS)
+- set_target_properties(${testname}
+- PROPERTIES LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS})
++ target_link_libraries(${testname} ${LIBALLEGRO4_LINK_FLAGS})
+ endif()
+
+ if(extra_definitions)
diff --git a/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch b/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch
new file mode 100644
index 000000000000..8f3027d4baf7
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch
@@ -0,0 +1,21 @@
+From 169edeaa69cce2670213c39232a249a487670883 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@hasufell.de>
+Date: Sun, 2 Nov 2014 16:58:33 +0100
+Subject: [PATCH] Fix underlinking with USE_SHARED_ALLEGRO4=ON
+
+---
+ src/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 21c3352..0ce11d2 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -58,6 +58,7 @@ if(USE_SHARED_ALLEGRO4)
+ OUTPUT_VARIABLE LIBALLEGRO4_LINK_FLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
++ set(LIBALLEGRO4_LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS} ${PLATFORM_LIBS})
+ include_directories(${LIBALLEGRO4_INCLUDE_DIR})
+ else()
+ add_definitions(-DALLEGRO4_WITH_RESIZE_PATCH)
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
new file mode 100644
index 000000000000..4536fc53a217
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
@@ -0,0 +1,27 @@
+From 9997ad9fcbb0dcef16e4e8224e4238ecdfe56b66 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20Mail=C3=A4nder?=
+ <Mailaender@users.noreply.github.com>
+Date: Sun, 28 Sep 2014 06:38:18 +0200
+Subject: [PATCH] always declare O_BINARY
+
+closes #461
+---
+ src/base/file_handle.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/base/file_handle.cpp b/src/base/file_handle.cpp
+index 0ba214e..f336513 100644
+--- a/src/base/file_handle.cpp
++++ b/src/base/file_handle.cpp
+@@ -21,6 +21,11 @@
+ #include <fcntl.h>
+ #endif
+
++#ifndef O_BINARY
++#define O_BINARY 0
++#define O_TEXT 0
++#endif
++
+ using namespace std;
+
+ namespace base {
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
new file mode 100644
index 000000000000..02fa48006646
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
@@ -0,0 +1,11 @@
+--- src/app/file/png_format.cpp
++++ src/app/file/png_format.cpp
+@@ -413,7 +413,7 @@
+ #endif
+
+ // Save the color palette.
+- palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * png_sizeof(png_color));
++ palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * sizeof(png_color));
+ for (c = 0; c < PNG_MAX_PALETTE_LENGTH; c++) {
+ fop_sequence_get_color(fop, c, &r, &g, &b);
+ palette[c].red = r;
diff --git a/dev-games/aseprite/metadata.xml b/dev-games/aseprite/metadata.xml
new file mode 100644
index 000000000000..21b446f5661b
--- /dev/null
+++ b/dev-games/aseprite/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Animated sprite editor and pixel art tool
+ </longdescription>
+ <use>
+ <flag name="memleak">Enable memory-leaks detector (only for developers)</flag>
+ <flag name="static">Link against static version of C and C++ runtimes</flag>
+ </use>
+</pkgmetadata>