summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-09-09 22:09:41 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-09-09 22:14:06 +0100
commit70f8c529e4a0639786ebcaec3dc15a6a18e94eb0 (patch)
tree36a6b7e1096395967bef39d6431afbf4ca5d6aff /dev-embedded
parentapp-office/homebank: Stabilize 5.8.2 amd64, #939395 (diff)
downloadgentoo-70f8c529e4a0639786ebcaec3dc15a6a18e94eb0.tar.gz
gentoo-70f8c529e4a0639786ebcaec3dc15a6a18e94eb0.tar.bz2
gentoo-70f8c529e4a0639786ebcaec3dc15a6a18e94eb0.zip
dev-embedded/raspberrypi-utils: Bump snapshot to 20240903
Fixes LTO issue. Bug: https://bugs.gentoo.org/926264 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/raspberrypi-utils/Manifest1
-rw-r--r--dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240903.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-embedded/raspberrypi-utils/Manifest b/dev-embedded/raspberrypi-utils/Manifest
index 24632d7cb267..e5914f26e539 100644
--- a/dev-embedded/raspberrypi-utils/Manifest
+++ b/dev-embedded/raspberrypi-utils/Manifest
@@ -1 +1,2 @@
DIST raspberrypi-utils-0_p20240203.tar.gz 122695 BLAKE2B 178b84b5210ba47a51e9815710b05d3916981f5413986cefcdb621420c9e9ab33b67026ea95692c6aff900dd2c31302059eb39aae32267b88cf765a7575f8bed SHA512 bdbe47d87a4bcd0d37ea4567e95e41fbc8240f5ffbc805d4a1f576060535af13e272b262ddad87dac0f9ea43b8b2ff9092378e67de080bd651701435b4c67008
+DIST raspberrypi-utils-0_p20240903.tar.gz 123998 BLAKE2B 4281fee7761df03b3a555d5e36f4bec1621c8402a5d5456752ab2d95482ca355e51d174f461ed8a1f89ed5d420a14d5f09872c090eccff6751d0c00ab20cf398 SHA512 96504004a1b7b541fe126d973f60321769a4b54a1b603b1d9278ba902bed7c008c2f86906dfaf30632ce75e1073b2a97e9317a799a0bc8cea255d713cb26ae67
diff --git a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240903.ebuild b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240903.ebuild
new file mode 100644
index 000000000000..0ede982eed41
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240903.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 cmake
+
+COMMIT="d4f8fb543a892ba65bfc608511bf582c0425aa81"
+
+DESCRIPTION="Raspberry Pi userspace utilities"
+HOMEPAGE="https://github.com/raspberrypi/utils"
+SRC_URI="https://github.com/raspberrypi/utils/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/utils-${COMMIT}"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+DEPEND="
+ sys-apps/dtc
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ !media-libs/raspberrypi-userland
+ !media-libs/raspberrypi-userland-bin
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-werror.patch
+)
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ local SRC
+ rm -r "${ED}"/usr/share/bash-completion/ || die
+ for SRC in */*-completion.bash; do
+ local DEST=${SRC%-completion.bash}
+ newbashcomp "${SRC}" "${DEST##*/}"
+ done
+}