summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-07 20:21:06 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-07 20:54:02 +0200
commit443eda5bdbf9ecbd8b056a9800361028c582ec39 (patch)
tree6657eed4293cd4a6036c151f5684930d3c86f7a7 /dev-embedded
parentsys-fs/genext2fs: add 1.5.0 (diff)
downloadgentoo-443eda5bdbf9ecbd8b056a9800361028c582ec39.tar.gz
gentoo-443eda5bdbf9ecbd8b056a9800361028c582ec39.tar.bz2
gentoo-443eda5bdbf9ecbd8b056a9800361028c582ec39.zip
dev-embedded/parapin: Fix tc-directly
- Port to EAPI-8 - Remove broken docs compilation Closes: https://bugs.gentoo.org/722632 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/parapin/files/parapin-1.5.0-tc-directly.patch23
-rw-r--r--dev-embedded/parapin/parapin-1.5.0-r1.ebuild (renamed from dev-embedded/parapin/parapin-1.5.0.ebuild)21
-rw-r--r--dev-embedded/parapin/parapin-1.5.1_beta1-r1.ebuild (renamed from dev-embedded/parapin/parapin-1.5.1_beta1.ebuild)26
3 files changed, 45 insertions, 25 deletions
diff --git a/dev-embedded/parapin/files/parapin-1.5.0-tc-directly.patch b/dev-embedded/parapin/files/parapin-1.5.0-tc-directly.patch
new file mode 100644
index 000000000000..0289a070e2c3
--- /dev/null
+++ b/dev-embedded/parapin/files/parapin-1.5.0-tc-directly.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile-2.4 b/Makefile-2.4
+index b900268..9946cef 100644
+--- a/Makefile-2.4
++++ b/Makefile-2.4
+@@ -43,9 +43,6 @@
+ LINUX_HEADERS := /usr/src/linux-`uname -r`/include/
+ LINUX_MODULES := /lib/modules/`uname -r`/kernel/
+
+-CC := gcc
+-CFLAGS := -O2 -g -Wall
+-
+ LIBPARAPIN_OBJS := parapin.o
+
+ EXAMPLE_DIR := examples
+@@ -82,7 +79,7 @@ allinstall: install modulesinstall $(BINDINGS)-install
+ ##### libraries
+
+ libparapin.a: $(LIBPARAPIN_OBJS)
+- ar -cr libparapin.a $(LIBPARAPIN_OBJS)
++ $(AR) -cr libparapin.a $(LIBPARAPIN_OBJS)
+
+ parapin.o: parapin.c parapin.h parapin-linux.h
+ $(CC) $(CFLAGS) -c parapin.c
diff --git a/dev-embedded/parapin/parapin-1.5.0.ebuild b/dev-embedded/parapin/parapin-1.5.0-r1.ebuild
index 0c172e5d1c89..eb1ca039789c 100644
--- a/dev-embedded/parapin/parapin-1.5.0.ebuild
+++ b/dev-embedded/parapin/parapin-1.5.0-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="A parallel port pin programming library"
@@ -13,25 +14,23 @@ IUSE="doc"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-DEPEND="doc? ( dev-tex/latex2html )"
+PATCHES=(
+ "${FILESDIR}"/${P}-tc-directly.patch
+)
src_compile() {
+ tc-export AR CC
# Note 2.4 and 2.6 makefiles are identical for the targets used
- emake -f Makefile-2.4 CC=$(tc-getCC)
- use doc && emake -C doc html
+ emake -f Makefile-2.4
}
src_install() {
+ einstalldocs
dolib.a libparapin.a
insopts -m0444; insinto /usr/include; doins parapin.h
- dodoc README
if use doc; then
- cd "${S}"/doc/${PN}
- docinto html
- dodoc *.html *.css *.png
-
- cd "${S}"/examples
+ cd examples || die
docinto examples
dodoc *.c
fi
diff --git a/dev-embedded/parapin/parapin-1.5.1_beta1.ebuild b/dev-embedded/parapin/parapin-1.5.1_beta1-r1.ebuild
index 51556291ee47..ec6e6a5c1db3 100644
--- a/dev-embedded/parapin/parapin-1.5.1_beta1.ebuild
+++ b/dev-embedded/parapin/parapin-1.5.1_beta1-r1.ebuild
@@ -1,39 +1,37 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="A parallel port pin programming library"
HOMEPAGE="http://parapin.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tgz"
+S="${WORKDIR}/${P/_/-}"
LICENSE="LGPL-2.1"
-IUSE="doc"
KEYWORDS="~amd64 ~x86"
SLOT="0"
+IUSE="doc"
-DEPEND="doc? ( dev-tex/latex2html )"
-
-S=${WORKDIR}/${P/_/-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-tc-directly.patch
+)
src_compile() {
+ tc-export AR CC
# Note 2.4 and 2.6 makefiles are identical for the targets used
- emake -f Makefile-2.4 CC=$(tc-getCC)
- use doc && emake -C doc html
+ emake -f Makefile-2.4
}
src_install() {
+ einstalldocs
dolib.a libparapin.a
insopts -m0444; insinto /usr/include; doins parapin.h
- dodoc README
if use doc; then
- cd "${S}"/doc/${PN}
- docinto html
- dodoc *.html *.css *.png
-
- cd "${S}"/examples
+ cd examples || die
docinto examples
dodoc *.c
fi