summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather Cynede <cynede@gentoo.org>2015-08-14 16:55:07 +0400
committerHeather Cynede <cynede@gentoo.org>2015-08-14 16:56:05 +0400
commit31fbca3f0c2f8b452716f647b77c3f7d1397cf9f (patch)
tree1b5bdffc34f6c5a20516cba43a11b297c0f3f4ad /dev-dotnet/xsp/xsp-2.10.2-r2.ebuild
parentmedia-plugins/mythplugins: Remove versions corresponding to removed mythtv (diff)
downloadgentoo-31fbca3f0c2f8b452716f647b77c3f7d1397cf9f.tar.gz
gentoo-31fbca3f0c2f8b452716f647b77c3f7d1397cf9f.tar.bz2
gentoo-31fbca3f0c2f8b452716f647b77c3f7d1397cf9f.zip
Revert "www-servers/xsp replaced by www-servers/xsp"
don't remove dev-dotnet/xsp awhile mod-mod and older monodevelop is using it
Diffstat (limited to 'dev-dotnet/xsp/xsp-2.10.2-r2.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-2.10.2-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-2.10.2-r2.ebuild b/dev-dotnet/xsp/xsp-2.10.2-r2.ebuild
new file mode 100644
index 000000000000..dcf35279a672
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-2.10.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils go-mono mono user
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Added try/catch around EndRequest Record sending, bug #432750
+ epatch "${FILESDIR}/${PN}-2.10.2-endrequest.patch"
+}
+
+src_configure() {
+ default
+}
+
+pkg_preinst() {
+ enewgroup aspnet
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+ mv_command="cp -ar" go-mono_src_install
+ newinitd "${PATCHDIR}"/xsp.initd xsp
+ newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
+ newconfd "${PATCHDIR}"/xsp.confd xsp
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}