summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/gio-sharp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/gio-sharp')
-rw-r--r--dev-dotnet/gio-sharp/Manifest1
-rw-r--r--dev-dotnet/gio-sharp/gio-sharp-0.3.ebuild46
-rw-r--r--dev-dotnet/gio-sharp/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-dotnet/gio-sharp/Manifest b/dev-dotnet/gio-sharp/Manifest
new file mode 100644
index 000000000000..dd259cfe8cd7
--- /dev/null
+++ b/dev-dotnet/gio-sharp/Manifest
@@ -0,0 +1 @@
+DIST gio-sharp-0.3.tar.gz 89752 SHA256 e800eafa4caf70d3b6b3db29c0ff9907ff416accfb7f324803f7014ef581a9c3 SHA512 69a3e5db422403fa756a25818a7db5adcf6c1bef81b1f10ce5dc4bdb63ea1462c3a9ea4a4f987b0e30dc444499258c1aac279005d045c8709187bae7f095a66a WHIRLPOOL e0a9e3b49b249c11747b51c6439e57d03d3f62ed4af0c0dc825f1224655315b3d3784759174dd7e7dec66a6ad30850480e9cd4bfa1c2541cb320eb8106d3daf6
diff --git a/dev-dotnet/gio-sharp/gio-sharp-0.3.ebuild b/dev-dotnet/gio-sharp/gio-sharp-0.3.ebuild
new file mode 100644
index 000000000000..95d640103f76
--- /dev/null
+++ b/dev-dotnet/gio-sharp/gio-sharp-0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools mono
+
+DESCRIPTION="GIO API C# binding"
+HOMEPAGE="http://github.com/mono/gio-sharp"
+SRC_URI="http://github.com/mono/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-dotnet/glib-sharp-2.12
+ >=dev-dotnet/gtk-sharp-gapi-2.12
+ >=dev-libs/glib-2.22:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+}
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ sed -i -e '/autoreconf/d' autogen-generic.sh || die
+ NOCONFIGURE=1 ./autogen-2.22.sh || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ mono_multilib_comply
+}
diff --git a/dev-dotnet/gio-sharp/metadata.xml b/dev-dotnet/gio-sharp/metadata.xml
new file mode 100644
index 000000000000..41b167255777
--- /dev/null
+++ b/dev-dotnet/gio-sharp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <upstream>
+ <remote-id type="github">mono/gio-sharp</remote-id>
+ </upstream>
+</pkgmetadata>