summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-21 05:45:27 +0100
committerSam James <sam@gentoo.org>2024-08-21 05:47:25 +0100
commit629ef453e0f9f68567c807416557e2d3c7b6780f (patch)
tree8f86bc970383496b28a33c2b3532ee5c30884648 /dev-debug
parentdev-debug/systemtap: add 5.1, add 9999 (diff)
downloadgentoo-629ef453e0f9f68567c807416557e2d3c7b6780f.tar.gz
gentoo-629ef453e0f9f68567c807416557e2d3c7b6780f.tar.bz2
gentoo-629ef453e0f9f68567c807416557e2d3c7b6780f.zip
dev-debug/systemtap: add comment wrt bash
I forgot to add this earlier. Turns out there's a bug for it too. Fixes: 818cec7cd4efae42c55af03f4c0617a95d069c14 Bug: https://bugs.gentoo.org/913947 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/systemtap/systemtap-5.1.ebuild2
-rw-r--r--dev-debug/systemtap/systemtap-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-debug/systemtap/systemtap-5.1.ebuild b/dev-debug/systemtap/systemtap-5.1.ebuild
index 56427628dd76..0bdad429da92 100644
--- a/dev-debug/systemtap/systemtap-5.1.ebuild
+++ b/dev-debug/systemtap/systemtap-5.1.ebuild
@@ -127,6 +127,8 @@ src_configure() {
$(use_with ssl nss)
$(use_with selinux)
)
+
+ # Use bash because of bashisms with brace expansion in Makefile.am (bug #913947)
CONFIG_SHELL="${BROOT}"/bin/bash PYTHON3="${PYTHON}" econf "${myeconfargs[@]}"
}
diff --git a/dev-debug/systemtap/systemtap-9999.ebuild b/dev-debug/systemtap/systemtap-9999.ebuild
index 56427628dd76..0bdad429da92 100644
--- a/dev-debug/systemtap/systemtap-9999.ebuild
+++ b/dev-debug/systemtap/systemtap-9999.ebuild
@@ -127,6 +127,8 @@ src_configure() {
$(use_with ssl nss)
$(use_with selinux)
)
+
+ # Use bash because of bashisms with brace expansion in Makefile.am (bug #913947)
CONFIG_SHELL="${BROOT}"/bin/bash PYTHON3="${PYTHON}" econf "${myeconfargs[@]}"
}