summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-22 13:20:46 +0100
committerSam James <sam@gentoo.org>2024-08-22 13:21:41 +0100
commitb2f1216adb56a434ab8e590cb530ce79c2e4da1a (patch)
treef0674a12a31a7961f6476d7bd12bdd2dcf209c98 /dev-debug/dtrace
parentapp-misc/openhab-bin: Stabilize 4.2.0-r1 ALLARCHES, #938307 (diff)
downloadgentoo-b2f1216adb56a434ab8e590cb530ce79c2e4da1a.tar.gz
gentoo-b2f1216adb56a434ab8e590cb530ce79c2e4da1a.tar.bz2
gentoo-b2f1216adb56a434ab8e590cb530ce79c2e4da1a.zip
dev-debug/dtrace: improve config checks further (mostly pedantry, also for tests)
This adds some technically-required-but-already-covered-by-dependencies CONFIG_* requirements in general, and then some real config requirements we were missing for the testsuite. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug/dtrace')
-rw-r--r--dev-debug/dtrace/dtrace-2.0.1.1-r1.ebuild12
-rw-r--r--dev-debug/dtrace/dtrace-9999.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/dev-debug/dtrace/dtrace-2.0.1.1-r1.ebuild b/dev-debug/dtrace/dtrace-2.0.1.1-r1.ebuild
index f084535e5911..04646e70ea08 100644
--- a/dev-debug/dtrace/dtrace-2.0.1.1-r1.ebuild
+++ b/dev-debug/dtrace/dtrace-2.0.1.1-r1.ebuild
@@ -85,12 +85,22 @@ pkg_pretend() {
CONFIG_CHECK+=" ~CUSE"
# Tracing
- CONFIG_CHECK+=" ~FTRACE_SYSCALLS ~UPROBE_EVENTS ~DYNAMIC_FTRACE ~FUNCTION_TRACER"
+ CONFIG_CHECK+=" ~TRACING"
+ CONFIG_CHECK+=" ~UPROBES ~UPROBE_EVENTS"
+ CONFIG_CHECK+=" ~FTRACE ~FTRACE_SYSCALLS ~DYNAMIC_FTRACE ~FUNCTION_TRACER"
CONFIG_CHECK+=" ~FPROBE"
+ # DTrace can fallback to kprobes for fbt but people often want them off
+ # for security and newer kernels work fine with BPF for that, so
+ # let's omit it.
# https://gcc.gnu.org/PR84052
CONFIG_CHECK+=" !GCC_PLUGIN_RANDSTRUCT"
+ if use install-tests ; then
+ # See test/modules
+ CONFIG_CHECK+=" ~EXT4_FS ~ISO9660_FS ~NFS_FS ~RDS ~TUN"
+ fi
+
check_extra_config
}
diff --git a/dev-debug/dtrace/dtrace-9999.ebuild b/dev-debug/dtrace/dtrace-9999.ebuild
index f084535e5911..04646e70ea08 100644
--- a/dev-debug/dtrace/dtrace-9999.ebuild
+++ b/dev-debug/dtrace/dtrace-9999.ebuild
@@ -85,12 +85,22 @@ pkg_pretend() {
CONFIG_CHECK+=" ~CUSE"
# Tracing
- CONFIG_CHECK+=" ~FTRACE_SYSCALLS ~UPROBE_EVENTS ~DYNAMIC_FTRACE ~FUNCTION_TRACER"
+ CONFIG_CHECK+=" ~TRACING"
+ CONFIG_CHECK+=" ~UPROBES ~UPROBE_EVENTS"
+ CONFIG_CHECK+=" ~FTRACE ~FTRACE_SYSCALLS ~DYNAMIC_FTRACE ~FUNCTION_TRACER"
CONFIG_CHECK+=" ~FPROBE"
+ # DTrace can fallback to kprobes for fbt but people often want them off
+ # for security and newer kernels work fine with BPF for that, so
+ # let's omit it.
# https://gcc.gnu.org/PR84052
CONFIG_CHECK+=" !GCC_PLUGIN_RANDSTRUCT"
+ if use install-tests ; then
+ # See test/modules
+ CONFIG_CHECK+=" ~EXT4_FS ~ISO9660_FS ~NFS_FS ~RDS ~TUN"
+ fi
+
check_extra_config
}