summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-06-13 08:30:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-06-13 08:30:29 +0000
commitde35cef3483ebf4575b99f5000ca5d58b6191691 (patch)
tree67ee7d705b7813abe865bfd549f6433c6a0fa82d /dev-db
parentdev-db/pgrouting: add 3.6.2 (diff)
downloadgentoo-de35cef3483ebf4575b99f5000ca5d58b6191691.tar.gz
gentoo-de35cef3483ebf4575b99f5000ca5d58b6191691.tar.bz2
gentoo-de35cef3483ebf4575b99f5000ca5d58b6191691.zip
dev-db/pgtap: add 1.3.3
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgtap/Manifest1
-rw-r--r--dev-db/pgtap/pgtap-1.3.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/pgtap/Manifest b/dev-db/pgtap/Manifest
index a015f57d011e..40b48a458551 100644
--- a/dev-db/pgtap/Manifest
+++ b/dev-db/pgtap/Manifest
@@ -1,2 +1,3 @@
DIST pgtap-1.2.0.zip 319374 BLAKE2B 1cea77860a1928ed7cbf4ddb0bb8ff418023bf88e377196ae2b505c065321e3003179227077567e676a8c551230d259ecd1cdb590001fc71bcc821b87fb3d0f6 SHA512 5569bea5e7879787a91fa9b2baae5cbff1db5b9a5a096db2a9a064012d65e02c52bd1520422b5e6f87fb5b6e64845371188ea53c43a277aee68ffc05d5152ed7
DIST pgtap-1.3.1.zip 654637 BLAKE2B 412dfcb51813552541f935328e28fbf8f0a014536a5eee8bf55ea680cd22a6424529641040627f91afebb407872d8d3d4aa25e576d965ddb11514229c2b72591 SHA512 98129bbbdf2221502e52375c3e55dff324e69cb930865d1589949ad2d96ddeac1a215e10d0612f7cc050d9a725817b01b23a9cc3e9cb42ef23a929e593ecb698
+DIST pgtap-1.3.3.zip 329966 BLAKE2B 03ba9f7af9dbb6a8077e5b6dd430171eef4afeb904c65f82b8b962af68852e32ad1dca57e710c8f722c5e2c10eeebe6c890dd3cc61e7c31257974dfaf19cb207 SHA512 6872208501498cb440e46fff9e9f953560551b60fbde11221a7c2d3ccc075780ad59585e0ab0639b630dd902d185b6844754cbc406eef4e4bf90e616adadf2b4
diff --git a/dev-db/pgtap/pgtap-1.3.3.ebuild b/dev-db/pgtap/pgtap-1.3.3.ebuild
new file mode 100644
index 000000000000..1d71d1666e21
--- /dev/null
+++ b/dev-db/pgtap/pgtap-1.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+POSTGRES_COMPAT=( {12..16} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_install() {
+ postgres-multi_src_install
+
+ rm -r "${ED}"/usr/share/doc/postgresql* || die "Failed to remove improper doc locations"
+ dodoc doc/pgtap.mmd
+}