summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2024-12-07 21:13:38 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-12-07 22:28:59 +0100
commit6618bfb015b8c23c9aeb4cee09e3fd7cab418d55 (patch)
tree43e6528ba24c0951c98e8820afeea4570b9d7219 /dev-db
parentnet-analyzer/gsad: add 24.1.0, drop 22.9.1 (diff)
downloadgentoo-6618bfb015b8c23c9aeb4cee09e3fd7cab418d55.tar.gz
gentoo-6618bfb015b8c23c9aeb4cee09e3fd7cab418d55.tar.bz2
gentoo-6618bfb015b8c23c9aeb4cee09e3fd7cab418d55.zip
dev-db/pg-gvm: add 22.6.6
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39627 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pg-gvm/Manifest1
-rw-r--r--dev-db/pg-gvm/pg-gvm-22.6.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/pg-gvm/Manifest b/dev-db/pg-gvm/Manifest
index fe0636597390..b3bbc903b1a9 100644
--- a/dev-db/pg-gvm/Manifest
+++ b/dev-db/pg-gvm/Manifest
@@ -1 +1,2 @@
DIST pg-gvm-22.6.4.tar.gz 39702 BLAKE2B d879f721c0d9d9d8f6942c889c37e37199671c5bb3fc4c5a38e5787d6f392c6c09bd5780907655445f9ad813e59e9d54242c1eac7fa513d4be71af8b85cc3790 SHA512 62ea4e982f6939f4eef0543209120fc7b1e0134630669c500289c9e68247b56dd861d802f93524a8eb4ad4c0585d38d11b8d3715cc2afc6e63cea5b6accd4bb6
+DIST pg-gvm-22.6.6.tar.gz 39921 BLAKE2B fab36a1aee90f384ec38f472bca5b46fb5f5e7cb32ac63443b3d9d2cb07a3b5203014abede918d37daba5fd13c3e43e9758ec7bc6e9640f1602c930bdffa6738 SHA512 062136a2940160b8295f36ec8936be90a3161b311d6632eed87a5c1cff2aca6a43ebe00ba3376a74beabd117ac3fe8fbedc767a4df6bfa5f26e5f3839a4f5ebf
diff --git a/dev-db/pg-gvm/pg-gvm-22.6.6.ebuild b/dev-db/pg-gvm/pg-gvm-22.6.6.ebuild
new file mode 100644
index 000000000000..e7a166109f11
--- /dev/null
+++ b/dev-db/pg-gvm/pg-gvm-22.6.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="Greenbone Library for helper functions in PostgreSQL"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/pg-gvm"
+SRC_URI="https://github.com/greenbone/pg-gvm/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=dev-libs/libical-1.0.0:=
+ >=net-analyzer/gvm-libs-22.6
+"
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-db/postgresql-9.6:=[uuid]
+"
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}