summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-17 11:43:01 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-17 11:44:07 +0200
commit3b23249e1250b929be1f5c59045528feb1ce7dd7 (patch)
treefee3711625c96bb5e4e3f78a1192218b5bc58e89 /dev-db/sqlitestudio
parentdev-db/sqlitestudio: bump 3.4.3 (diff)
downloadgentoo-3b23249e1250b929be1f5c59045528feb1ce7dd7.tar.gz
gentoo-3b23249e1250b929be1f5c59045528feb1ce7dd7.tar.bz2
gentoo-3b23249e1250b929be1f5c59045528feb1ce7dd7.zip
dev-db/sqlitestudio: fix install with FEATURES=test
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-db/sqlitestudio')
-rw-r--r--dev-db/sqlitestudio/metadata.xml3
-rw-r--r--dev-db/sqlitestudio/sqlitestudio-3.4.3.ebuild6
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-db/sqlitestudio/metadata.xml b/dev-db/sqlitestudio/metadata.xml
index 8d910856df4f..b42fb8ee3067 100644
--- a/dev-db/sqlitestudio/metadata.xml
+++ b/dev-db/sqlitestudio/metadata.xml
@@ -5,4 +5,7 @@
<use>
<flag name="cli">Build CLI interface</flag>
</use>
+ <upstream>
+ <remote-id type="github">pawelsalawa/sqlitestudio</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-db/sqlitestudio/sqlitestudio-3.4.3.ebuild b/dev-db/sqlitestudio/sqlitestudio-3.4.3.ebuild
index 1e3253c24a3a..9392b3336487 100644
--- a/dev-db/sqlitestudio/sqlitestudio-3.4.3.ebuild
+++ b/dev-db/sqlitestudio/sqlitestudio-3.4.3.ebuild
@@ -164,15 +164,15 @@ src_compile() {
}
src_install() {
+ emake -C "${core_build_dir}" INSTALL_ROOT="${D}" install
+ emake -C "${plugins_build_dir}" INSTALL_ROOT="${D}" install
+
if use test; then
# remove test artifacts that must not be installed
rm -r "${ED}"/lib64 || die
rm -r "${ED}"/usr/share/qt5/tests || die
fi
- emake -C "${core_build_dir}" INSTALL_ROOT="${D}" install
- emake -C "${plugins_build_dir}" INSTALL_ROOT="${D}" install
-
doicon -s scalable "SQLiteStudio3/guiSQLiteStudio/img/${PN}.svg"
local make_desktop_entry_args=(