summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2017-10-21 17:58:44 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-22 02:03:03 +0200
commit62eab3c77e0eab212b5f358e2682bb77deff8702 (patch)
tree9c0aa66e2a9ae787006cf47af9b9c56ed4e0ebda /dev-db/sqliteman/sqliteman-1.2.2-r4.ebuild
parentdev-java/java-sdk-docs: Version bump to 1.8.0.152 (diff)
downloadgentoo-62eab3c77e0eab212b5f358e2682bb77deff8702.tar.gz
gentoo-62eab3c77e0eab212b5f358e2682bb77deff8702.tar.bz2
gentoo-62eab3c77e0eab212b5f358e2682bb77deff8702.zip
dev-db/sqliteman: Depend on x11-libs/qscintilla[qt5]
Gentoo-bug: 634982 Closes: https://github.com/gentoo/gentoo/pull/6002
Diffstat (limited to 'dev-db/sqliteman/sqliteman-1.2.2-r4.ebuild')
-rw-r--r--dev-db/sqliteman/sqliteman-1.2.2-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/sqliteman/sqliteman-1.2.2-r4.ebuild b/dev-db/sqliteman/sqliteman-1.2.2-r4.ebuild
new file mode 100644
index 000000000000..a7645ef0f775
--- /dev/null
+++ b/dev-db/sqliteman/sqliteman-1.2.2-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+QT_VER=5.7.1
+inherit cmake-utils flag-o-matic xdg-utils
+
+DESCRIPTION="Powerful GUI manager for the Sqlite3 database"
+HOMEPAGE="https://sourceforge.net/projects/sqliteman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtcore-${QT_VER}:5
+ >=dev-qt/qtgui-${QT_VER}:5
+ >=dev-qt/qtsql-${QT_VER}:5[sqlite]
+ >=dev-qt/qtwidgets-${QT_VER}:5
+ >=x11-libs/qscintilla-2.9.4:=[qt5(+)]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-lpthread.patch"
+ "${FILESDIR}/${P}-qt5.patch"
+)
+
+src_prepare() {
+ # remove bundled lib
+ rm -rf "${S}"/${PN}/qscintilla2 || die
+
+ append-flags -fPIC
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}