summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2015-10-23 21:18:51 +0200
committerMike Gilbert <floppym@gentoo.org>2015-10-23 15:22:37 -0400
commitab6604a68ee222119673d5b02f1c4c5b85438667 (patch)
tree9f144ad8b9b783ed7815eaad2cc7df61ccb8d2e9 /dev-db/sqlite
parentnet-misc/ntp: Security version bump for bug #563774 (diff)
downloadgentoo-ab6604a68ee222119673d5b02f1c4c5b85438667.tar.gz
gentoo-ab6604a68ee222119673d5b02f1c4c5b85438667.tar.bz2
gentoo-ab6604a68ee222119673d5b02f1c4c5b85438667.zip
dev-db/sqlite: Fix building with USE="-tcl -test tools".
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/sqlite-3.9.1.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-db/sqlite/sqlite-3.9.1.ebuild b/dev-db/sqlite/sqlite-3.9.1.ebuild
index 90bf609b6dc0..235974de7fd9 100644
--- a/dev-db/sqlite/sqlite-3.9.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.9.1.ebuild
@@ -162,13 +162,9 @@ multilib_src_configure() {
# static-libs USE flag.
options+=($(use_enable static-libs static))
- # tcl, test USE flags.
+ # tcl, test, tools USE flags.
if full_tarball; then
- if use tcl || use test; then
- options+=(--enable-tcl)
- else
- options+=(--disable-tcl)
- fi
+ options+=(--enable-tcl)
fi
if [[ "${CHOST}" == *-mint* ]]; then
@@ -189,7 +185,7 @@ multilib_src_configure() {
}
multilib_src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
+ emake HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
if use tools && multilib_is_native_abi; then
emake showdb showjournal showstat4 showwal sqldiff sqlite3_analyzer
@@ -202,7 +198,7 @@ multilib_src_test() {
return
fi
- emake $(use debug && echo fulltest || echo test)
+ emake HAVE_TCL="$(usex tcl 1 "")" $(use debug && echo fulltest || echo test)
}
multilib_src_install() {