summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-06-18 06:18:35 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-06-18 06:19:01 -0400
commit05bd97b6606eac693c58b850dc9119330ddd3ea6 (patch)
tree1e7fc00b3d8474e6b7def93b4553ebd6187bb848 /dev-db/psqlodbc
parentnet-vpn/i2pd: remove old (diff)
downloadgentoo-05bd97b6606eac693c58b850dc9119330ddd3ea6.tar.gz
gentoo-05bd97b6606eac693c58b850dc9119330ddd3ea6.tar.bz2
gentoo-05bd97b6606eac693c58b850dc9119330ddd3ea6.zip
dev-db/psqlodbc: Bump to 11.01.0000
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/psqlodbc')
-rw-r--r--dev-db/psqlodbc/Manifest1
-rw-r--r--dev-db/psqlodbc/psqlodbc-11.01.0000.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/Manifest b/dev-db/psqlodbc/Manifest
index d4491ead0195..d5b84adfeece 100644
--- a/dev-db/psqlodbc/Manifest
+++ b/dev-db/psqlodbc/Manifest
@@ -1 +1,2 @@
DIST psqlodbc-10.01.0000.tar.gz 915109 BLAKE2B a09de8218dbfbacf7972fc02c02863891ed65d19b86217a646aa0176ad7a8b962da83bb5036ad11b819a583409e4d1f3ce257a0457838000bc9cc060753c67b3 SHA512 1c5b9732a9c7e7bff0fd0a04cc7f0b45db9150486a2c3a8a96d85fb55e9296a80f12ee652cfb7ff54700e7dfc10accf9e5420b7ca798df31be51f997bbda88aa
+DIST psqlodbc-11.01.0000.tar.gz 919372 BLAKE2B ce84b4bb210c4c3c3f2a3e9eae713c875e4bae491e20f207f740a02af69cb771f504de6b1da06fcd12306d986299e1537184a6787eac80e320eea6d8c13dc142 SHA512 57762bfa9925012946e56a3d5b815af00078299c121ba0142865c06f877cabf314512e4e6efc654589fb409c4dd2cbb9a3b7fd7aa1a6ace361879552774b11d7
diff --git a/dev-db/psqlodbc/psqlodbc-11.01.0000.ebuild b/dev-db/psqlodbc/psqlodbc-11.01.0000.ebuild
new file mode 100644
index 000000000000..395aee1903ac
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-11.01.0000.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="https://odbc.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iodbc ssl threads"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dodoc docs/*{html,jpg,txt}
+}