summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/pg_activity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/pg_activity')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/metadata.xml11
-rw-r--r--dev-db/pg_activity/pg_activity-1.2.0.ebuild25
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
new file mode 100644
index 000000000000..79483d3df98c
--- /dev/null
+++ b/dev-db/pg_activity/Manifest
@@ -0,0 +1 @@
+DIST pg_activity-1.2.0.tar.gz 88863 SHA256 e93f09263f9111963818dafe6a8f166ed9c1b272e56e046925d7524ebf779d92 SHA512 0bf2f3f746755cb3bc6cbff6a9377d172b15a82c836a19cd52ef8073c39cbb8ffaf2f9583fca437cabc7251bab55a874e1ee8e0559778881d42bcc030bf5d0c4 WHIRLPOOL ec8f5d414290bdbb59821ca37cd1a0d098db3771e7d51f0f4f5125c999889a69bf0a71e94288ee7d0e90821b78f5eef3d907f5eac46a5e8e6a5bcf68a241163b
diff --git a/dev-db/pg_activity/metadata.xml b/dev-db/pg_activity/metadata.xml
new file mode 100644
index 000000000000..f6601797b296
--- /dev/null
+++ b/dev-db/pg_activity/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ago@gentoo.org</email>
+ <name>Agostino Sarubbo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">julmon/pg_activity</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pg_activity/pg_activity-1.2.0.ebuild b/dev-db/pg_activity/pg_activity-1.2.0.ebuild
new file mode 100644
index 000000000000..ca7439b0e77c
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/julmon/pg_activity/"
+SRC_URI="https://github.com/julmon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+DEPEND=""
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}