summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
commit128c4b0b6c73f994174bf351d311ed021adbc6f7 (patch)
treeb29ea0b846a53af1bc54ded701368dd2ff5f638a /dev-db/mysql
parentwww-apps/prowlarr: drop 1.0.0.2171 (diff)
downloadgentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.gz
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.bz2
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.zip
*/*: make mycmakeargs local
Closes: https://github.com/gentoo/gentoo/pull/28947 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/mysql-5.7.36-r1.ebuild4
-rw-r--r--dev-db/mysql/mysql-5.7.40.ebuild2
-rw-r--r--dev-db/mysql/mysql-8.0.27.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/dev-db/mysql/mysql-5.7.36-r1.ebuild b/dev-db/mysql/mysql-5.7.36-r1.ebuild
index 482b873a518e..4679a6ef6089 100644
--- a/dev-db/mysql/mysql-5.7.36-r1.ebuild
+++ b/dev-db/mysql/mysql-5.7.36-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -290,7 +290,7 @@ multilib_src_configure() {
CMAKE_BUILD_TYPE="RelWithDebInfo"
# debug hack wrt #497532
- mycmakeargs=(
+ local mycmakeargs=(
-DCMAKE_C_FLAGS_RELWITHDEBINFO="$(usex debug '' '-DNDEBUG')"
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO="$(usex debug '' '-DNDEBUG')"
-DMYSQL_DATADIR="${EPREFIX}/var/lib/mysql"
diff --git a/dev-db/mysql/mysql-5.7.40.ebuild b/dev-db/mysql/mysql-5.7.40.ebuild
index e22e7215d2bc..19f47c417c89 100644
--- a/dev-db/mysql/mysql-5.7.40.ebuild
+++ b/dev-db/mysql/mysql-5.7.40.ebuild
@@ -289,7 +289,7 @@ multilib_src_configure() {
CMAKE_BUILD_TYPE="RelWithDebInfo"
# debug hack wrt #497532
- mycmakeargs=(
+ local mycmakeargs=(
-DCMAKE_C_FLAGS_RELWITHDEBINFO="$(usex debug '' '-DNDEBUG')"
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO="$(usex debug '' '-DNDEBUG')"
-DMYSQL_DATADIR="${EPREFIX}/var/lib/mysql"
diff --git a/dev-db/mysql/mysql-8.0.27.ebuild b/dev-db/mysql/mysql-8.0.27.ebuild
index 0a2cedce470c..87825505d12d 100644
--- a/dev-db/mysql/mysql-8.0.27.ebuild
+++ b/dev-db/mysql/mysql-8.0.27.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -202,7 +202,7 @@ src_configure() {
CMAKE_BUILD_TYPE="RelWithDebInfo"
# debug hack wrt #497532
- mycmakeargs=(
+ local mycmakeargs=(
-DCMAKE_C_FLAGS_RELWITHDEBINFO="$(usex debug '' '-DNDEBUG')"
-DCMAKE_CXX_FLAGS_RELWITHDEBINFO="$(usex debug '' '-DNDEBUG')"
-DMYSQL_DATADIR="${EPREFIX}/var/lib/mysql"