summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-08 10:58:44 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-08 10:58:44 +0200
commit9b58cf14be1dd0bf854e93ed326074d0b7464d18 (patch)
tree84d493fe67da8ee029c248ef2ea8a288f95b6461 /dev-db/mysql-workbench
parentdev-ruby/axiom-types: enable ruby32 (diff)
downloadgentoo-9b58cf14be1dd0bf854e93ed326074d0b7464d18.tar.gz
gentoo-9b58cf14be1dd0bf854e93ed326074d0b7464d18.tar.bz2
gentoo-9b58cf14be1dd0bf854e93ed326074d0b7464d18.zip
dev-db/mysql-workbench: fix gcc13 compilation
Thanks to Alex D-Bug for the patch. Closes: https://bugs.gentoo.org/905758 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-db/mysql-workbench')
-rw-r--r--dev-db/mysql-workbench/files/mysql-workbench-8.0.33-gcc13.patch40
-rw-r--r--dev-db/mysql-workbench/mysql-workbench-8.0.33.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/mysql-workbench/files/mysql-workbench-8.0.33-gcc13.patch b/dev-db/mysql-workbench/files/mysql-workbench-8.0.33-gcc13.patch
new file mode 100644
index 000000000000..7fbbc145d4bf
--- /dev/null
+++ b/dev-db/mysql-workbench/files/mysql-workbench-8.0.33-gcc13.patch
@@ -0,0 +1,40 @@
+--- mysql-workbench-community-8.0.33-src/library/forms/mforms/mforms.h.orig 2023-06-30 14:43:47.056539087 +0300
++++ mysql-workbench-community-8.0.33-src/library/forms/mforms/mforms.h 2023-06-30 14:44:11.500537735 +0300
+@@ -61,6 +61,7 @@
+ *
+ */
+
++#include <cstdint>
+ #include "mforms/view.h"
+ #include "mforms/form.h"
+ #include "mforms/button.h"
+--- mysql-workbench-community-8.0.33-src/library/cdbc/src/driver_manager.h.orig 2023-06-30 14:51:19.804514044 +0300
++++ mysql-workbench-community-8.0.33-src/library/cdbc/src/driver_manager.h 2023-06-30 14:51:30.333513462 +0300
+@@ -27,6 +27,7 @@
+ #include "cppdbc_public_interface.h"
+
+ #include <cppconn/driver.h>
++#include <cstdint>
+ #include <memory>
+ #include <set>
+
+--- mysql-workbench-community-8.0.33-src/library/forms/mforms/treeview.h.orig 2023-06-30 17:08:50.534057671 +0300
++++ mysql-workbench-community-8.0.33-src/library/forms/mforms/treeview.h 2023-06-30 17:10:33.945051951 +0300
+@@ -23,6 +23,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <mforms/view.h>
+
+ /**
+--- mysql-workbench-community-8.0.33-src/backend/wbpublic/sqlide/sqlide_generics_private.h.orig 2023-06-30 17:51:48.242915090 +0300
++++ mysql-workbench-community-8.0.33-src/backend/wbpublic/sqlide/sqlide_generics_private.h 2023-06-30 17:52:26.461912976 +0300
+@@ -24,6 +24,7 @@
+ #ifndef _SQLIDE_GENERICS_PRIVATE_H_
+ #define _SQLIDE_GENERICS_PRIVATE_H_
+
++#include <cstdint>
+ #include "wbpublic_public_interface.h"
+ #include <sqlite/database_exception.hpp>
+ #include <sqlite/result.hpp>
diff --git a/dev-db/mysql-workbench/mysql-workbench-8.0.33.ebuild b/dev-db/mysql-workbench/mysql-workbench-8.0.33.ebuild
index c7a1e0a6bc79..5a4074147d36 100644
--- a/dev-db/mysql-workbench/mysql-workbench-8.0.33.ebuild
+++ b/dev-db/mysql-workbench/mysql-workbench-8.0.33.ebuild
@@ -70,6 +70,7 @@ S="${WORKDIR}"/"${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-6.2.5-wbcopytables.patch"
"${FILESDIR}/${PN}-8.0.19-mysql-connector-8.patch"
+ "${FILESDIR}/${PN}-8.0.33-gcc13.patch"
)
src_unpack() {