summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-19 22:58:52 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-19 22:58:52 +0200
commit84e6d4115cf108b358344bfea894f31d67b7f681 (patch)
tree67a2bd1d9b815c9fa01cc514bfcfe28e11a28a9e /dev-db/datadraw/datadraw-3.1.1.ebuild
parentdev-python/pytest-mock: Stabilize 3.3.1 ALLARCHES, #743472 (diff)
downloadgentoo-84e6d4115cf108b358344bfea894f31d67b7f681.tar.gz
gentoo-84e6d4115cf108b358344bfea894f31d67b7f681.tar.bz2
gentoo-84e6d4115cf108b358344bfea894f31d67b7f681.zip
dev-db/datadraw: Port to EAPI 7
Closes: https://bugs.gentoo.org/710804 Closes: https://bugs.gentoo.org/722610 Closes: https://bugs.gentoo.org/742068 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/datadraw/datadraw-3.1.1.ebuild')
-rw-r--r--dev-db/datadraw/datadraw-3.1.1.ebuild48
1 files changed, 21 insertions, 27 deletions
diff --git a/dev-db/datadraw/datadraw-3.1.1.ebuild b/dev-db/datadraw/datadraw-3.1.1.ebuild
index 608c45988c11..584245a0341e 100644
--- a/dev-db/datadraw/datadraw-3.1.1.ebuild
+++ b/dev-db/datadraw/datadraw-3.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="feature rich database generator for high performance C applications"
HOMEPAGE="http://datadraw.sourceforge.net/"
@@ -12,39 +12,33 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PN}${PV}/${PN}${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
+IUSE="examples"
-DEPEND=""
-RDEPEND=""
+S="${WORKDIR}/${PN}${PV}"
-S=${WORKDIR}/${PN}${PV}
+PATCHES=( "${FILESDIR}"/${P}-buildsystem.patch )
-src_prepare() {
- tc-export CC
- sed -e "/^CFLAGS=/s:-g -Wall:${CFLAGS}:" \
- -i configure \
- -i dataview/configure \
- -i util/configure || die
-
- sed -e '/^datadraw:/,+2s:\\$(CFLAGS):\\$(CFLAGS) \\$(LDFLAGS):' \
- -i configure || die
+src_configure() {
+ tc-export AR CC
+ default
}
src_install() {
- dobin ${PN}
+ dobin datadraw
- insinto /usr/$(get_libdir)
- for lib in util/*.a ; do
- newins ${lib} lib$(basename ${lib})
+ local lib
+ for lib in util/*.a; do
+ newlib.a ${lib} lib${lib#*/}
done
- insinto /usr/include
- doins util/*.h
+ doheader util/*.h
+
+ HTML_DOCS=( www/index.html www/images )
+ einstalldocs
+ dodoc manual.pdf
- dodoc README
- if use doc ; then
- dodoc manual.pdf
- dohtml -r www/index.html www/images
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
- use examples && dodoc -r examples
}