summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-01-09 08:31:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-01-09 08:32:37 +0000
commit59e2bf49bf18d7f3716f267a8f041d18f47301e3 (patch)
tree3699965a6545d8265b43b12d97c937b87b54a218 /dev-db/citus
parentdev-db/citus: add 11.1.5 (diff)
downloadgentoo-59e2bf49bf18d7f3716f267a8f041d18f47301e3.tar.gz
gentoo-59e2bf49bf18d7f3716f267a8f041d18f47301e3.tar.bz2
gentoo-59e2bf49bf18d7f3716f267a8f041d18f47301e3.zip
dev-db/citus: add 11.0.7
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/citus')
-rw-r--r--dev-db/citus/citus-11.0.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/citus/citus-11.0.7.ebuild b/dev-db/citus/citus-11.0.7.ebuild
new file mode 100644
index 000000000000..1b91866bc2b8
--- /dev/null
+++ b/dev-db/citus/citus-11.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 13 14 15 )
+
+inherit postgres-multi
+
+DESCRIPTION="Open-source postgresql extension for clustering/multi-node setups"
+HOMEPAGE="https://www.citusdata.com/"
+
+MY_PV="${PV/beta0/beta}"
+SRC_URI="https://github.com/citusdata/citus/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+IUSE=""
+LICENSE="POSTGRESQL AGPL-3"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/lz4
+ app-arch/zstd
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ postgres-multi_foreach econf
+}