summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/bucardo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/bucardo')
-rw-r--r--dev-db/bucardo/Manifest3
-rw-r--r--dev-db/bucardo/bucardo-5.1.1-r1.ebuild32
-rw-r--r--dev-db/bucardo/bucardo-5.2.0.ebuild32
-rw-r--r--dev-db/bucardo/bucardo-5.3.1.ebuild32
-rw-r--r--dev-db/bucardo/metadata.xml5
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-db/bucardo/Manifest b/dev-db/bucardo/Manifest
new file mode 100644
index 000000000000..4a4dc44fe419
--- /dev/null
+++ b/dev-db/bucardo/Manifest
@@ -0,0 +1,3 @@
+DIST Bucardo-5.1.1.tar.gz 313409 SHA256 73fec278e83ccd561050d24816438db34d0b68fb9bc44bf4d27c5885ad31597f SHA512 cfba0ad5bd305a057688e024b11dce8332ebada2a5ca649481311cd46e140d6fc57c71914570fe7f26beb9c6e5ac232d36450bed9017ae932117cf28561d311a WHIRLPOOL d8d4848e2e817d648bc9aa4102d00e6da981098f0baf10af3239c1818aa51fba890670788acdf2b0af6f87f3b2fc987a44918d45ab3a304ebd32e536430f0167
+DIST Bucardo-5.2.0.tar.gz 318481 SHA256 3b6353b5cf28e45e1ad612f3aea884dabd19823374cc38eeec8364390d5a94ad SHA512 179c72d3a6cd756a725b3f37e2d6dc30df5d473e90a479f22d6a2ca4e6e98f55c1aa12d92ae4958d4446f5f1176fad4c5c0085d38cf3c64f77b699e3bf0884dd WHIRLPOOL 8c76910c97f9252473cd7575a08fea9f6c536d58f66ab596274fec514e220edbd20ea0fac75dc739757702e1b9ee47181240f348ace74ca7f7cf9121a6f85d9c
+DIST Bucardo-5.3.1.tar.gz 321942 SHA256 de8f83305395571cff8c6db8e0016b195424ed75116012528d283dd789c2c132 SHA512 c0821116b81523016b1b7cd9f7544b575c9b762fea1a721f57648dd8484fbc8881fa10fc4a81166239b3a4b50072dfdb8075e5f1485c96c37265d023b0f4ac27 WHIRLPOOL acf5bb82a83d49f979301fe2941c884be0773e1180929d2973e3f6b781f610ea3650498141655b59c2e15dd581d555e4e2314f4d8762ffa323209d4146dab82c
diff --git a/dev-db/bucardo/bucardo-5.1.1-r1.ebuild b/dev-db/bucardo/bucardo-5.1.1-r1.ebuild
new file mode 100644
index 000000000000..842dc1235925
--- /dev/null
+++ b/dev-db/bucardo/bucardo-5.1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+RESTRICT="test"
+
+inherit perl-module
+
+MY_PN="Bucardo"
+
+DESCRIPTION="An asynchronous PostgreSQL replication system"
+HOMEPAGE="http://bucardo.org/wiki/Bucardo"
+SRC_URI="http://bucardo.org/downloads/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="test" doesn't work without extra data
+IUSE=""
+
+DEPEND="dev-perl/DBIx-Safe
+ dev-perl/DBD-Pg"
+RDEPEND="dev-perl/DBIx-Safe"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_BASE="${D}" install -j1
+ keepdir /var/run/bucardo
+}
diff --git a/dev-db/bucardo/bucardo-5.2.0.ebuild b/dev-db/bucardo/bucardo-5.2.0.ebuild
new file mode 100644
index 000000000000..842dc1235925
--- /dev/null
+++ b/dev-db/bucardo/bucardo-5.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+RESTRICT="test"
+
+inherit perl-module
+
+MY_PN="Bucardo"
+
+DESCRIPTION="An asynchronous PostgreSQL replication system"
+HOMEPAGE="http://bucardo.org/wiki/Bucardo"
+SRC_URI="http://bucardo.org/downloads/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="test" doesn't work without extra data
+IUSE=""
+
+DEPEND="dev-perl/DBIx-Safe
+ dev-perl/DBD-Pg"
+RDEPEND="dev-perl/DBIx-Safe"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_BASE="${D}" install -j1
+ keepdir /var/run/bucardo
+}
diff --git a/dev-db/bucardo/bucardo-5.3.1.ebuild b/dev-db/bucardo/bucardo-5.3.1.ebuild
new file mode 100644
index 000000000000..8337c3ae4088
--- /dev/null
+++ b/dev-db/bucardo/bucardo-5.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+RESTRICT="test"
+
+inherit perl-module
+
+MY_PN="Bucardo"
+
+DESCRIPTION="An asynchronous PostgreSQL replication system"
+HOMEPAGE="http://bucardo.org/wiki/Bucardo"
+SRC_URI="http://bucardo.org/downloads/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="test" doesn't work without extra data
+IUSE=""
+
+DEPEND="dev-perl/DBIx-Safe
+ dev-perl/DBD-Pg"
+RDEPEND="dev-perl/DBIx-Safe"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_BASE="${D}" install -j1
+ keepdir /var/run/bucardo
+}
diff --git a/dev-db/bucardo/metadata.xml b/dev-db/bucardo/metadata.xml
new file mode 100644
index 000000000000..d06e452b35af
--- /dev/null
+++ b/dev-db/bucardo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>postgresql</herd>
+</pkgmetadata>