summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-23 22:26:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-23 22:27:17 +0300
commitea9420785e5f14c4a7a49eaaacbcb4399e0ea7ed (patch)
treee540820c80f61e6bb9faca4f842b44b0bf1e6e39 /dev-cpp
parentsys-kernel/genkernel: bump json to 0.17 (diff)
downloadgentoo-ea9420785e5f14c4a7a49eaaacbcb4399e0ea7ed.tar.gz
gentoo-ea9420785e5f14c4a7a49eaaacbcb4399e0ea7ed.tar.bz2
gentoo-ea9420785e5f14c4a7a49eaaacbcb4399e0ea7ed.zip
dev-cpp/gtkmm: EAPI 6 -> 8
Checked by comparing hashes of built stuff Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.24.5-r2.ebuild (renamed from dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild)14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild b/dev-cpp/gtkmm/gtkmm-2.24.5-r2.ebuild
index d70b1362ca74..362b10e1252c 100644
--- a/dev-cpp/gtkmm/gtkmm-2.24.5-r1.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.24.5-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit gnome2 multilib-minimal
@@ -23,12 +23,14 @@ RDEPEND="
>=dev-cpp/pangomm-2.34.0:1.4[${MULTILIB_USEDEP}]
>=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? (
- media-gfx/graphviz
+ app-text/doxygen
dev-libs/libxslt
- app-text/doxygen )
+ media-gfx/graphviz
+ )
"
src_prepare() {
@@ -39,7 +41,7 @@ src_prepare() {
fi
if ! use examples; then
- # don't waste time building tests
+ # don't waste time building examples
sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed 2 failed"
fi
@@ -59,6 +61,6 @@ multilib_src_install() {
}
multilib_src_install_all() {
- DOCS="AUTHORS ChangeLog PORTING NEWS README"
+ local DOCS=( AUTHORS ChangeLog PORTING NEWS README )
einstalldocs
}