summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-27 07:42:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-27 08:10:34 -0400
commitd54c9a9b7a637f2b43edf4bbb2c134d7c9f21bd1 (patch)
tree00c89770c7391144e508a80bd5fb43d4c7f7dee6 /dev-cpp
parentvirtual/skkserv: unkeyword 0-r1 for ~riscv (diff)
downloadgentoo-d54c9a9b7a637f2b43edf4bbb2c134d7c9f21bd1.tar.gz
gentoo-d54c9a9b7a637f2b43edf4bbb2c134d7c9f21bd1.tar.bz2
gentoo-d54c9a9b7a637f2b43edf4bbb2c134d7c9f21bd1.zip
dev-cpp/simpleini: drop 4.22
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch8
-rw-r--r--dev-cpp/simpleini/simpleini-4.22.ebuild36
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch b/dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch
deleted file mode 100644
index 1250a01f3ca2..000000000000
--- a/dev-cpp/simpleini/files/simpleini-4.20-pkgconfig-var.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-Use $(PKG_CONFIG), and also avoid repeating the calls for every objects.
---- a/tests/Makefile
-+++ b/tests/Makefile
-@@ -2,2 +2,2 @@
--CXXFLAGS+=-Wall -std=c++14 `pkg-config --cflags gtest_main`
--LDFLAGS+=`pkg-config --libs gtest_main`
-+CXXFLAGS:=-Wall -std=c++14 $(shell $(PKG_CONFIG) --cflags gtest_main) $(CXXFLAGS)
-+LDFLAGS:=$(LDFLAGS) $(shell $(PKG_CONFIG) --libs gtest_main)
diff --git a/dev-cpp/simpleini/simpleini-4.22.ebuild b/dev-cpp/simpleini/simpleini-4.22.ebuild
deleted file mode 100644
index ccc5bfadc70d..000000000000
--- a/dev-cpp/simpleini/simpleini-4.22.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="C++ library providing a simple API to read and write INI-style files"
-HOMEPAGE="https://github.com/brofield/simpleini/"
-SRC_URI="https://github.com/brofield/simpleini/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/gtest )"
-BDEPEND="test? ( virtual/pkgconfig )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.20-pkgconfig-var.patch
-)
-
-src_compile() {
- if use test; then
- tc-export CXX PKG_CONFIG
- emake -C tests "${emakeargs[@]}"
- fi
-}
-
-src_install() {
- # note: this skips ConvertUTF, can use -DSI_CONVERT_ICU instead if needed
- emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
- einstalldocs
-}