summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-11 17:37:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-14 23:55:29 +0100
commitcb1e5069e03ad2bd2a3d99a753e8b514ef873659 (patch)
treea6cb439375c6ce013bf9138501268cdaf7895e3f /dev-cpp
parentnet-libs/kdsoap-ws-discovery-client: add 0.3.0 (diff)
downloadgentoo-cb1e5069e03ad2bd2a3d99a753e8b514ef873659.tar.gz
gentoo-cb1e5069e03ad2bd2a3d99a753e8b514ef873659.tar.bz2
gentoo-cb1e5069e03ad2bd2a3d99a753e8b514ef873659.zip
dev-cpp/libcmis: 0.6.0 version bump, new slot
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libcmis/Manifest2
-rw-r--r--dev-cpp/libcmis/libcmis-0.6.0.ebuild65
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild8
3 files changed, 71 insertions, 4 deletions
diff --git a/dev-cpp/libcmis/Manifest b/dev-cpp/libcmis/Manifest
index 6dd6b81353db..63cfc415531c 100644
--- a/dev-cpp/libcmis/Manifest
+++ b/dev-cpp/libcmis/Manifest
@@ -1,2 +1,4 @@
DIST libcmis-0.5.2-patchset.tar.xz 16632 BLAKE2B 0a9802955059214428e7c2d6171093b171e47899de05404ee462bbf2c68c808927759a0808d79aa3aa9c8b9cd1a60b55686f7596b121701704a2d9720d6a8ba8 SHA512 bca4cc908e5510a9f597d6f1b560b3bbfdcda185b79d21320c6e3f7e5c559b7dda375407dfd6f05420b6f4edd666f6e7e70b7b72808506acc22fdfdab344f52c
DIST libcmis-0.5.2.tar.gz 295020 BLAKE2B 325eacedd87eb1888a439c727a648c5aeb8d58c9b80add9761ffc55381193b71b589865d13ecd55177faafa935642685001f60456c1354e037989b29e9451c05 SHA512 45d8cd6d420a9593b46e1f2d6fbf384ea248cb218b0db6326ee2f082ff29100b65a2cc999ccb849e61df4f4ed7c3721b09addc6c322ef03c6c93f8c0acc02bde
+DIST libcmis-0.6.0-patchset.tar.xz 2728 BLAKE2B 264c6ef7a273449c0887c9a2891e8df44517df0b274303037e57946ff44c9186e7e54a6ca3919b530d9f0c1750bb711f524c3e45474a1dabbb66e2bce129b10c SHA512 7325edb0e19a0bee953a853086c4289a7e6edbd6a885fedf6bbfdff48bd5a3170538be196f404d36f629964b21de404c256c4bc1310f7ca5e2bf25e10043b5a7
+DIST libcmis-0.6.0.tar.gz 294976 BLAKE2B b78ead81577a0edf3a47dfae6672bf27e54c5ee8f37b0f145a61eaca792565187d346a1c60544d5ee0cf00d3b6f38d7e77ebaae5202a1d61cf43a280734a9b93 SHA512 b9de99b0693793eec7936d6c42d75ef67145c6767a66aea5c665cd99022911a6da5d6ceedf9054e009a696ba47e8b4e4b80003670209840f388f7a9ad1cd8bf5
diff --git a/dev-cpp/libcmis/libcmis-0.6.0.ebuild b/dev-cpp/libcmis/libcmis-0.6.0.ebuild
new file mode 100644
index 000000000000..f24a427bd144
--- /dev/null
+++ b/dev-cpp/libcmis/libcmis-0.6.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
+ inherit git-r3
+else
+ PATCHSET="${P}-patchset"
+ SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}.tar.xz"
+# KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="https://github.com/tdf/libcmis"
+
+LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
+SLOT="0.6"
+IUSE="man test tools"
+
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/boost:=
+ dev-libs/libxml2
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ man? (
+ app-text/docbook2X
+ dev-libs/libxslt
+ )
+ test? (
+ dev-util/cppcheck
+ dev-util/cppunit
+ )
+"
+
+PATCHES=( "${WORKDIR}/${PATCHSET}" ) # from git master, to be 0.6.1
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --program-suffix=-${SLOT}
+ --disable-werror
+ $(use_with man)
+ $(use_enable test tests)
+ $(use_enable tools client)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 10de5182674b..3ab040210d77 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
inherit autotools
@@ -16,7 +16,7 @@ DESCRIPTION="C++ client library for the CMIS interface"
HOMEPAGE="https://github.com/tdf/libcmis"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.5"
+SLOT="0.6"
IUSE="man test tools"
RESTRICT="test"
@@ -46,7 +46,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --program-suffix=-$(ver_cut 1-2)
+ --program-suffix=-${SLOT}
--disable-werror
$(use_with man)
$(use_enable test tests)