summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-18 13:35:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-18 18:28:04 +0100
commit822e64bf02212670af36addc9c7153ac22d24e9b (patch)
treebd7b7be63f99dcaea79451f1193cb1dec307d4be /dev-cpp
parentdev-cpp/pangomm: use ${EPYTHON}, not python3 (diff)
downloadgentoo-822e64bf02212670af36addc9c7153ac22d24e9b.tar.gz
gentoo-822e64bf02212670af36addc9c7153ac22d24e9b.tar.bz2
gentoo-822e64bf02212670af36addc9c7153ac22d24e9b.zip
dev-cpp/atkmm: use ${EPYTHON}, not python3
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/770883 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/atkmm/atkmm-2.28.1.ebuild5
-rw-r--r--dev-cpp/atkmm/atkmm-2.36.0.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-cpp/atkmm/atkmm-2.28.1.ebuild b/dev-cpp/atkmm/atkmm-2.28.1.ebuild
index 5e871abf8b61..01366db0ae40 100644
--- a/dev-cpp/atkmm/atkmm-2.28.1.ebuild
+++ b/dev-cpp/atkmm/atkmm-2.28.1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org meson multilib-minimal
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
DESCRIPTION="C++ interface for the ATK library"
HOMEPAGE="https://www.gtkmm.org"
@@ -25,6 +27,7 @@ BDEPEND="
dev-lang/perl
dev-libs/libxslt
)
+ ${PYTHON_DEPS}
"
multilib_src_configure() {
diff --git a/dev-cpp/atkmm/atkmm-2.36.0.ebuild b/dev-cpp/atkmm/atkmm-2.36.0.ebuild
index 6d37b606cc4d..0ab832b961c8 100644
--- a/dev-cpp/atkmm/atkmm-2.36.0.ebuild
+++ b/dev-cpp/atkmm/atkmm-2.36.0.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org meson multilib-minimal
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org meson multilib-minimal python-any-r1
DESCRIPTION="C++ interface for the ATK library"
HOMEPAGE="https://www.gtkmm.org"
@@ -25,6 +27,7 @@ BDEPEND="
dev-lang/perl
dev-libs/libxslt
)
+ ${PYTHON_DEPS}
"
multilib_src_configure() {