summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-06-12 14:27:24 +0100
committerMarek Szuba <marecki@gentoo.org>2024-06-12 14:51:58 +0100
commit6d646da840ac77a5e76bb884d06ded46d846f3ad (patch)
tree1d77aabbd9f0d6ce197a3508ed076ae4a4498ea8 /dev-cpp
parentdev-cpp/clhpp: drop IUSE=test from older versions (diff)
downloadgentoo-6d646da840ac77a5e76bb884d06ded46d846f3ad.tar.gz
gentoo-6d646da840ac77a5e76bb884d06ded46d846f3ad.tar.bz2
gentoo-6d646da840ac77a5e76bb884d06ded46d846f3ad.zip
dev-cpp/clhpp: add 2024.05.08
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/clhpp/Manifest1
-rw-r--r--dev-cpp/clhpp/clhpp-2024.05.08.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/clhpp/Manifest b/dev-cpp/clhpp/Manifest
index 07f4c4777c3d..439e4604bd54 100644
--- a/dev-cpp/clhpp/Manifest
+++ b/dev-cpp/clhpp/Manifest
@@ -1,2 +1,3 @@
DIST clhpp-2023.04.17.tar.gz 115042 BLAKE2B df0db751eda9fe2f23a5e3ef97f263885a09ca4b341b24c9580522e84a192e9afe526a441d0e3660e8819492945b2ff89bff7c96cd1fd1b3bd6a177042ec759e SHA512 1e37af647a37737240de1622bd772e1f154a07c2d27e020487163c42d0833096c1a2f2f2185b8f6371889c2cad3992f0c7a9d233c36941367da743ee7ee8e486
DIST clhpp-2023.12.14.tar.gz 123233 BLAKE2B 2b23639ad162921e01033fbacc1c4e57d9c28ce39c55b3564f162e5d6b6d9ed0e80aaefbd62de81157e165f01897e82d0ff4943c8ee620587840f4aece22319b SHA512 a90152d2f9c57d4724ef3ea33e1311914e49659042e916e467a9f16877d348ed62f909fe8423589976669b25241a3b996fbd7ac235a44e35947d1b87d3e3ef2b
+DIST clhpp-2024.05.08.tar.gz 124818 BLAKE2B 57b22e1911d8e21b4f7bef1f39f9910dd80eb50844dc7c18b3c75e311991a37577a0671d9e1b10ff3fb3302568118e3fb69987beec6fbe8fc8da85fcd7addda0 SHA512 6396cd67a2edef6a76695857e3e45f7eeb8cdaa8c729197357c6374ac58b41caa37bbe8c3b7a1724d43d3805f8cd5edd53a8ed833d6415bf072745800b744572
diff --git a/dev-cpp/clhpp/clhpp-2024.05.08.ebuild b/dev-cpp/clhpp/clhpp-2024.05.08.ebuild
new file mode 100644
index 000000000000..cfd7e4b5e780
--- /dev/null
+++ b/dev-cpp/clhpp/clhpp-2024.05.08.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="OpenCL-CLHPP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Khronos OpenCL C++ bindings"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP/"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="Khronos-CLHPP"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Tests require CMock (NOT cmocka), which is currently not in Gentoo
+# and has been found to be extremely awkward to package.
+# Should it ever get packaged, consult git history for how to set things up
+# for the clhpp test suite.
+RESTRICT="test"
+
+RDEPEND="virtual/opencl"
+DEPEND="${RDEPEND}
+ >=dev-util/opencl-headers-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_TESTING=OFF
+ )
+ cmake_src_configure
+}