summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-06-19 12:08:09 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-06-19 13:26:32 -0500
commit59a319267dc55c49e8789d935f55a8b4fd94f4af (patch)
treed865dc356e191f62265470e9156989cb2fdf47c1 /dev-cpp
parentdev-cpp/kokkos: update maintainers (diff)
downloadgentoo-59a319267dc55c49e8789d935f55a8b4fd94f4af.tar.gz
gentoo-59a319267dc55c49e8789d935f55a8b4fd94f4af.tar.bz2
gentoo-59a319267dc55c49e8789d935f55a8b4fd94f4af.zip
dev-cpp/kokkos: add 4.0.1
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/kokkos/Manifest1
-rw-r--r--dev-cpp/kokkos/kokkos-4.0.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-cpp/kokkos/Manifest b/dev-cpp/kokkos/Manifest
index aead5200cb02..5a04b2ab21bf 100644
--- a/dev-cpp/kokkos/Manifest
+++ b/dev-cpp/kokkos/Manifest
@@ -1 +1,2 @@
DIST kokkos-3.7.1.tar.gz 2305103 BLAKE2B c94493077190c1e5d2681d0e138012fcd82f91a1f7616ea7373f3c12f577a195937d507dd2d64f82902fa6760f63da8b3e2c1ef31a7114b9da21841280e22e33 SHA512 97cb7e05aec145ba9adae30b20ae3138a532db3a56cdd5e092d8f9c1e1788efe7a6f721282e2a5c5bf9c0da4c53d28f30b27fcb546b68aa8eaa589a362eb40c1
+DIST kokkos-4.0.1.tar.gz 2322402 BLAKE2B a4aba2f7ffe7b7c93051ad65d398f442b753975eceb3f83ed1bff0b8c468e4ffdcb6437989e740c65fc550f17ef8ddf78ca50ca881d3953f886309dc7d6fc597 SHA512 cf6742f4be777b52673858b49cf68fdf335e760509688483e62ef41af5026070f69dcf39d010134c85dc6c4868f82a38900872be11ed43190432c8530b90deee
diff --git a/dev-cpp/kokkos/kokkos-4.0.1.ebuild b/dev-cpp/kokkos/kokkos-4.0.1.ebuild
new file mode 100644
index 000000000000..4ec60171c232
--- /dev/null
+++ b/dev-cpp/kokkos/kokkos-4.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="C++ Performance Portability Programming EcoSystem"
+HOMEPAGE="https://github.com/kokkos"
+MY_PV="$(ver_cut 1-2).0$(ver_cut 3)"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 -x86"
+IUSE="+openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sys-apps/hwloc:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/kokkos
+ -DKokkos_ENABLE_TESTS=$(usex test)
+ -DKokkos_ENABLE_AGGRESSIVE_VECTORIZATION=ON
+ -DKokkos_ENABLE_SERIAL=ON
+ -DKokkos_ENABLE_HWLOC=ON
+ -DKokkos_HWLOC_DIR="${EPREFIX}/usr"
+ -DKokkos_ENABLE_OPENMP=$(usex openmp)
+ -DBUILD_SHARED_LIBS=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Contains "death tests" which are known/expected(?) to fail
+ # https://github.com/kokkos/kokkos/issues/3033
+ # bug #791514
+ -E "(KokkosCore_UnitTest_OpenMP|KokkosCore_UnitTest_Serial)"
+ )
+
+ cmake_src_test
+}