summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-11 01:11:39 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-11 01:11:39 +0200
commit122712fa3c2465a5a35699bb939cd34032f0740b (patch)
tree24ab8b3311863c2b4a0764147ac70062065a4e68 /dev-cpp
parentx11-terms/xterm: Version bump to 327 (diff)
downloadgentoo-122712fa3c2465a5a35699bb939cd34032f0740b.tar.gz
gentoo-122712fa3c2465a5a35699bb939cd34032f0740b.tar.bz2
gentoo-122712fa3c2465a5a35699bb939cd34032f0740b.zip
dev-cpp/muParser: Version bump to 2.2.5
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/muParser/Manifest1
-rw-r--r--dev-cpp/muParser/muParser-2.2.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/muParser/Manifest b/dev-cpp/muParser/Manifest
index cb7dc48f97b9..2c36d6fe76a5 100644
--- a/dev-cpp/muParser/Manifest
+++ b/dev-cpp/muParser/Manifest
@@ -1 +1,2 @@
+DIST muParser-2.2.5.tar.gz 761315 SHA256 0666ef55da72c3e356ca85b6a0084d56b05dd740c3c21d26d372085aa2c6e708 SHA512 d89380ebdc0ce91d0ea38fe43419ab6ed06c47d352b9ee20e1edcce48337b464366153493e0241c373ba2880a8b419fb9541e56cda0d14915daf9b98136ee682 WHIRLPOOL 86b8d4c13982b4748abbc379b6a2e4d421fc5d734b36daa8ed9525d451404996f0099404464908f144c5be3319db2cbbc92d697a5c56326bc303cc48a4f9520b
DIST muparser_v2_2_3.zip 1481359 SHA256 dfe831b69392ab0b1eb59d3601b7b1575554a85057cf2f234f64f930c4148902 SHA512 86d140c07161757e2f0de516a4c2922ce5b135d06b01466bc15ad90833bd3e9f99b9b9c528617262597a7a5a6b09bff5ae8ced5d51c413ea611059e0bdb22e6d WHIRLPOOL 3a53d04382feec889c4a54fe2edf762d9cf8629f4ec0543cfde12b6848e3594391a778c54747d6b4cf7608fcc0ac557f71132741935716704b160601057ff312
diff --git a/dev-cpp/muParser/muParser-2.2.5.ebuild b/dev-cpp/muParser/muParser-2.2.5.ebuild
new file mode 100644
index 000000000000..eb93d49c9f67
--- /dev/null
+++ b/dev-cpp/muParser/muParser-2.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="http://muparser.beltoforion.de/"
+SRC_URI="https://github.com/beltoforion/muparser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc test"
+
+S=${WORKDIR}/muparser-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.32-parallel-build.patch
+ sed -i \
+ -e 's:-O2::g' \
+ configure || die
+}
+
+src_configure() {
+ econf $(use_enable test samples)
+}
+
+src_test() {
+ cat > test.sh <<- EOFTEST
+ LD_LIBRARY_PATH="${S}/lib" samples/example1/example1 <<- EOF
+ quit
+ EOF
+ EOFTEST
+ sh ./test.sh || die "test failed"
+}
+
+src_install() {
+ default
+ dodoc Changes.txt
+}