summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Skala <mskala@gmx.com>2018-06-06 19:23:01 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-09 18:26:43 +0200
commit24360b0832cdb61c65989e7b90560f03bfca32e3 (patch)
tree79d48b2233415d38480b587243b7d1e647e3a849 /dev-cpp/websocketpp
parent/home/mattst88/projects/gentoo: Fix vaapi config (diff)
downloadgentoo-24360b0832cdb61c65989e7b90560f03bfca32e3.tar.gz
gentoo-24360b0832cdb61c65989e7b90560f03bfca32e3.tar.bz2
gentoo-24360b0832cdb61c65989e7b90560f03bfca32e3.zip
dev-cpp/websocketpp: Fix lib install dir
Closes: https://github.com/gentoo/gentoo/pull/8736 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'dev-cpp/websocketpp')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild b/dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..5102455cf018
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# bug 630450
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_CMAKE_DIR="$(get_libdir)/cmake/${PN}"
+ -DENABLE_CPP11="$(usex !boost)"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use examples && DOCS=( examples/ )
+ cmake-utils_src_install
+}