summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-21 21:46:00 +0000
committerSam James <sam@gentoo.org>2022-12-21 22:25:11 +0000
commit8d42bc88d3811261be33fd19b62c1416c6ebff7d (patch)
tree3490b2b0bc3960b49143117672d61749e92935f1 /dev-cpp/nlohmann_json
parentdev-libs/pugixml: drop 1.12 (diff)
downloadgentoo-8d42bc88d3811261be33fd19b62c1416c6ebff7d.tar.gz
gentoo-8d42bc88d3811261be33fd19b62c1416c6ebff7d.tar.bz2
gentoo-8d42bc88d3811261be33fd19b62c1416c6ebff7d.zip
dev-cpp/nlohmann_json: drop 3.10.5
Bug: https://bugs.gentoo.org/886907 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/nlohmann_json')
-rw-r--r--dev-cpp/nlohmann_json/Manifest2
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild59
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 84ce2923e94b..0ebb96ff79c9 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,4 +1,2 @@
-DIST nlohmann_json-3.10.5.tar.gz 7021996 BLAKE2B d4219d2f3168341eb8bd8f84af364e53f6caae67aa080b1ca0479216a98ee0256d5436243273b3c12ccdca904b4b17dbb90cf445fc273424d7dab6d2b95632bc SHA512 4a9d6416f383e76bf95425fc02a4e12c605fcbcae910b704e354396a493454cf8a1ffbecba11f231e020ffd2842908df7e67dbc09f62d1202d40b6815c24cfd2
DIST nlohmann_json-3.11.2.tar.gz 8097673 BLAKE2B ebb67966739a330e0cfb8495a6eb58e87732655856a6d4e843072ed5e485cafbb8a75d8803859d0365b814deda7429448ecc473de414de4b23d3a3c455dc2511 SHA512 70097c9bcd7a91254acbd41b8b68a6aaa371fc2dd7011f472917f69f1e2d2986155a0339dad791699d542e4a3be44dc49ae72ff73d0ee0ea4b34183296ce19a0
-DIST nlohmann_json-testdata-3.0.0.tar.gz 112348454 BLAKE2B f0a47b41805bf1426f612e9a82efea2a3e5b1c15740c1c531d859e60dc5daeb85209b4fe363fd8fb84e3bbf01a2578c74538ba3e769726494047979f5a4d468d SHA512 d9af8419b837c592ec7519cd5772651c761078a9c43cf2a309cee55c323aee0df0c233fb58a07d5ee2e77492ac8b16398de234b387eae037a60e3c9ba5b08891
DIST nlohmann_json-testdata-3.1.0.tar.gz 115036393 BLAKE2B 809be0728a0b9d007fcc752911bdf6f7e548d6e3ec59871ea2b16d87d8248ca4dd2f681a1d0f82c618463294188ad41d6d965b8bdc39c70fdcf4b939d4121e9c SHA512 db6c411b37f2154f5dd1ed90f4e8fa0907f4a736cd0ff79943bcacf9da422285ff142bb6a7dc6022b236090083166ac1ab197be3f480d8dc50b26a91a9477821
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
deleted file mode 100644
index 3a1cf56d78ce..000000000000
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-#DOCS_BUILDER="mkdocs"
-# Needs unpackaged plantuml-markdown too
-# ... but plantuml (Python bindings anyway) need network access to generate bits at runtime.
-#DOCS_DEPEND="dev-python/mkdocs-material-extensions dev-python/mkdocs-minify-plugin"
-#DOCS_DIR="doc/mkdocs"
-inherit cmake
-
-# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
-TEST_VERSION="3.0.0"
-DESCRIPTION="JSON for Modern C++"
-HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="
- https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
-S="${WORKDIR}/json-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ppc64 ~riscv x86"
-IUSE="test"
-# Need to report failing tests upstream
-# Tests only just added, large test suite, majority pass
-RESTRICT="test"
-
-DOCS=( ChangeLog.md README.md )
-
-src_configure() {
- # Tests are built by default so we can't group the test logic below
- local mycmakeargs=(
- -DJSON_MultipleHeaders=ON
- -DJSON_BuildTests=$(usex test)
- )
-
- # Define test data directory here to avoid unused var QA warning, bug #747826
- use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-}
-
-src_test() {
- cd "${BUILD_DIR}/test" || die
-
- # Skip certain tests needing git per upstream
- # https://github.com/nlohmann/json/issues/2189
- local myctestargs=(
- "-LE git_required"
- )
-
- cmake_src_test
-}