summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-11 17:56:55 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-11 17:57:18 +0200
commit928b17486c5c731485befc769175476ee877c6fb (patch)
treed3445a6966fee2cdad39e43d35d68175104da74a /dev-cpp/glog/glog-0.4.0.ebuild
parentdev-cpp/glog: restrict tests (diff)
downloadgentoo-928b17486c5c731485befc769175476ee877c6fb.tar.gz
gentoo-928b17486c5c731485befc769175476ee877c6fb.tar.bz2
gentoo-928b17486c5c731485befc769175476ee877c6fb.zip
dev-cpp/glog: bump to v0.4.0
Closes: https://bugs.gentoo.org/682622 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-cpp/glog/glog-0.4.0.ebuild')
-rw-r--r--dev-cpp/glog/glog-0.4.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-cpp/glog/glog-0.4.0.ebuild b/dev-cpp/glog/glog-0.4.0.ebuild
new file mode 100644
index 000000000000..c5097b33e782
--- /dev/null
+++ b/dev-cpp/glog/glog-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Google's C++ logging library"
+HOMEPAGE="https://github.com/google/glog"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+RESTRICT="test"
+
+RDEPENDS="sys-libs/libunwind[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-fix-x32-build.patch
+ "${FILESDIR}"/${PN}-0.4.0-errnos.patch
+ "${FILESDIR}"/${PN}-0.4.0-fix-test-on-ports.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}