summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-21 23:53:59 +0100
committerSam James <sam@gentoo.org>2024-06-21 23:53:59 +0100
commitca8656c4317eb59f3186c79f851ff8aac23eca48 (patch)
tree9e2cdd010304cca6b93a2248f5625a78cc4dcaf0 /dev-build
parentapp-arch/xz-utils: simplify PGO (diff)
downloadgentoo-ca8656c4317eb59f3186c79f851ff8aac23eca48.tar.gz
gentoo-ca8656c4317eb59f3186c79f851ff8aac23eca48.tar.bz2
gentoo-ca8656c4317eb59f3186c79f851ff8aac23eca48.zip
dev-build/automake: add 1.16.92 (unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/automake/Manifest2
-rw-r--r--dev-build/automake/automake-1.16.92.ebuild148
2 files changed, 150 insertions, 0 deletions
diff --git a/dev-build/automake/Manifest b/dev-build/automake/Manifest
index 91fc191e87be..1b8cfc0a6ff3 100644
--- a/dev-build/automake/Manifest
+++ b/dev-build/automake/Manifest
@@ -4,3 +4,5 @@ DIST automake-1.16.5.tar.xz 1601740 BLAKE2B 87408abc57e1d4317a2b518fb3606d0f6d15
DIST automake-1.16.5.tar.xz.sig 833 BLAKE2B a79fcdce97e13ac3bf39d73e183da92703681ff80011974d95a41be20169f95414551985f7a46602fba3558e33f24d6dcb76222d99f9de4fef0d3dc59b88807e SHA512 032a7c39abb4cabbefa4eb9c15263baec0902e48c0c81364307361a41fd55be282b9640707c789f5ae572e8e60240e34d1b575a671b5710f5d2a5716fafc2d51
DIST automake-1.16.90.tar.xz 1644220 BLAKE2B 01a4ddfccbbdd96976b1801c767ef2ff6951a09eb7e0071a7b8e7c8c768fae1accc4a6a38290109995710b9296a2ac1e0dcf8d03a3f6ec42e4d69d25b3ff106e SHA512 139a2777be1417e02a7701a8e0166d4961fe50e3bddc79e2e852727fc1032b7f85ad0bee6ddc8bfd796a02c75a464500e984295290dac5614a7d6039dae9c52d
DIST automake-1.16.90.tar.xz.sig 833 BLAKE2B c77fa1a99a7638b570f26f4858486d20b83801a661549e82ac4f7b7e9fd9c7dd2211e2403fc13b65a488d05d7a3c81ae7a372988c4a7e2e0588e4d7d609c77b5 SHA512 f4fc6ff3e1158bc37f95375f4eb2497e5bd9bb943a7d418e94379fcd292b9f35357b842b8a7383c942b23bf5510b61b17b997231267fb6f55dad7bab00b954e2
+DIST automake-1.16.92.tar.xz 1649420 BLAKE2B aa7c50d9d8f2d9b9444530c24bf694c031909f96164cb3f335e793ae1244f34253903123e26ce9cd50724c60fa47cbcee5ae4c59b8a2d955d8f8363480050a71 SHA512 47609fcbe962195b6683d3ccc62bda7f86af0bb702148caa4aa7e21ce1b49ae4c238254817b51ea7afdaa671d183ec43fc4af41b676cd1afafec8e485142e2fc
+DIST automake-1.16.92.tar.xz.sig 833 BLAKE2B 0ad23cea8e865be0e928fb3feaee4f982de59e1c60322465f44acb7126dee5ab13d2010757f23f60960819345399ff5ba1f80dee7cbc4483c7adf3413b6025e4 SHA512 1df37c983b70250383084b2dcdba543e9c32a028a842ca6dd7cb8a3f17dba5edfb4372a87c03d2da1053ea5a72e45972e0ae1f0492b78463bae437e7b0dad6b4
diff --git a/dev-build/automake/automake-1.16.92.ebuild b/dev-build/automake/automake-1.16.92.ebuild
new file mode 100644
index 000000000000..ac793c1acd3d
--- /dev/null
+++ b/dev-build/automake/automake-1.16.92.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bumping notes:
+# * Remember to modify LAST_KNOWN_AUTOMAKE_VER 'upstream' in dev-build/automake-wrapper
+# on new automake (major) releases, as well as the dependency in RDEPEND below too.
+# * Update _WANT_AUTOMAKE and _automake_atom case statement in autotools.eclass.
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-any-r1 verify-sig
+
+MANGLED_SLOT=${PV:0:4}
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_MIN_CLONE_TYPE=single
+ EGIT_REPO_URI="https://git.savannah.gnu.org/r/${PN}.git"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/jimmeyering.asc
+ if [[ $(ver_cut 3) -ge 90 ]] ; then
+ MANGLED_SLOT=$(ver_cut 1).$(($(ver_cut 2) + 1))
+ SRC_URI="
+ https://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz
+ verify-sig? (
+ https://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz.sig
+ )
+ "
+ else
+ SRC_URI="
+ mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? (
+ mirror://gnu/${PN}/${P}.tar.xz.sig
+ )
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ fi
+fi
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="https://www.gnu.org/software/automake/"
+
+LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
+SLOT="${MANGLED_SLOT}"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/perl-5.6
+ >=dev-build/automake-wrapper-20240607
+ >=dev-build/autoconf-2.69:*
+ sys-devel/gnuconfig
+"
+BDEPEND="
+ app-alternatives/gzip
+ sys-apps/help2man
+ dev-build/autoconf-wrapper
+ dev-build/autoconf
+ test? (
+ ${PYTHON_DEPS}
+ dev-util/dejagnu
+ sys-devel/bison
+ sys-devel/flex
+ )
+ verify-sig? ( sec-keys/openpgp-keys-jimmeyering )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ export WANT_AUTOCONF=2.5
+ # Don't try wrapping the autotools - this thing runs as it tends
+ # to be a bit esoteric, and the script does `set -e` itself.
+ ./bootstrap || die
+ sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
+
+ # bug #628912
+ if ! has_version -b sys-apps/texinfo ; then
+ touch doc/{stamp-vti,version.texi,automake.info} || die
+ fi
+}
+
+src_configure() {
+ # Also used in install.
+ infopath="${EPREFIX}/usr/share/automake-${PV}/info"
+ econf --infodir="${infopath}"
+}
+
+src_test() {
+ # Fails with byacc/flex
+ emake YACC="bison -y" LEX="flex" check
+}
+
+src_install() {
+ default
+
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
+ rm \
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ local x
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
+ done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile="${ED}/usr/share/doc/${PF}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
+
+ pushd "${D}/${infopath}" >/dev/null || die
+ for f in *.info*; do
+ # Install convenience aliases for versioned Automake pages.
+ ln -s "$f" "${f/./-${PV}.}" || die
+ done
+ popd >/dev/null || die
+
+ if [[ ${PV} == 9999 ]]; then
+ local major="89"
+ local minor="999"
+ else
+ local major="$(ver_cut 1)"
+ if [[ $(ver_cut 3) -ge 90 ]] ; then
+ local minor=$(($(ver_cut 2) + 1))
+ else
+ local minor="$(ver_cut 2)"
+ fi
+ fi
+ local idx="$((99999-(major*1000+minor)))"
+ newenvd - "06automake${idx}" <<-EOF
+ INFOPATH="${infopath}"
+ EOF
+
+ docompress "${MY_INFODIR}"
+}