summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-12-19 10:32:29 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-12-19 10:32:29 +0100
commit9c629c34c4d245facc867e068119c0b52456a850 (patch)
treec77281ef950c6a2b95f187c7000f303fda5b05b9 /dev-ada
parentdev-ada/gnatcoll-bindings: using trampoline (diff)
downloadgentoo-9c629c34c4d245facc867e068119c0b52456a850.tar.gz
gentoo-9c629c34c4d245facc867e068119c0b52456a850.tar.bz2
gentoo-9c629c34c4d245facc867e068119c0b52456a850.zip
dev-ada/gnatcoll-core: build something
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-22.0.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-22.0.0.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-22.0.0.ebuild
index 58f464be487e..3d1edf36345a 100644
--- a/dev-ada/gnatcoll-core/gnatcoll-core-22.0.0.ebuild
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-22.0.0.ebuild
@@ -14,6 +14,8 @@ LICENSE="GPL-3"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+shared static-libs static-pic"
+REQUIRED_USE="|| ( shared static-libs static-pic )
+ ${ADA_REQUIRED_USE}"
RDEPEND="
|| (
@@ -25,8 +27,6 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
src_prepare() {
@@ -51,12 +51,12 @@ src_compile() {
if use shared; then
build relocatable
fi
- if use static-pic; then
- build static-pic
- fi
if use static-libs; then
build static
fi
+ if use static-pic; then
+ build static-pic
+ fi
}
src_install() {