summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-05-31 20:26:22 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-05-31 20:26:22 +0200
commitb7a0e12e3ab2f75eb96bc96e7351eb59b1ee3a9d (patch)
tree1c50c4b8676eb3002cb8744d2b0e22cd4cf4594d /dev-ada/aws/aws-2018-r1.ebuild
parentapp-admin/rsyslog: bump to v8.1905.0 (diff)
downloadgentoo-b7a0e12e3ab2f75eb96bc96e7351eb59b1ee3a9d.tar.gz
gentoo-b7a0e12e3ab2f75eb96bc96e7351eb59b1ee3a9d.tar.bz2
gentoo-b7a0e12e3ab2f75eb96bc96e7351eb59b1ee3a9d.zip
dev-ada/aws: enable build with gnat-gpl-2019
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ada/aws/aws-2018-r1.ebuild')
-rw-r--r--dev-ada/aws/aws-2018-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ada/aws/aws-2018-r1.ebuild b/dev-ada/aws/aws-2018-r1.ebuild
new file mode 100644
index 000000000000..14d971edcf9c
--- /dev/null
+++ b/dev-ada/aws/aws-2018-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multiprocessing
+
+MY_P=${PN}-gpl-${PV}-src
+
+DESCRIPTION="A complete Web development framework"
+HOMEPAGE="http://libre.adacore.com/tools/aws/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819e0c7a447df26c27abd
+ -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnat_2016 gnat_2017 +gnat_2018 gnat_2019"
+
+RDEPEND="dev-ada/xmlada[gnat_2016=,gnat_2017=,gnat_2018(-)=,gnat_2019(-)=]
+ dev-ada/xmlada[shared,static-libs]"
+DEPEND="${RDEPEND}
+ gnat_2016? ( dev-ada/asis[gnat_2016] )
+ gnat_2017? ( dev-ada/asis[gnat_2017] )
+ gnat_2018? ( dev-ada/asis[gnat_2018] )
+ gnat_2019? ( dev-ada/asis[gnat_2019] )
+ dev-ada/gprbuild[gnat_2016=,gnat_2017=,gnat_2018(-)=,gnat_2019(-)=]"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2016-gentoo.patch
+ "${FILESDIR}"/${PN}-2018-gentoo.patch
+)
+
+src_configure() {
+ emake -j1 setup prefix=/usr ENABLE_SHARED=true \
+ GPRBUILD="/usr/bin/gprbuild -v"
+}
+
+src_compile() {
+ emake \
+ PROCESSORS=$(makeopts_jobs) \
+ GPRBUILD="/usr/bin/gprbuild -v"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}