summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-01-13 13:39:36 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-01-13 16:06:02 -0800
commitb2216e2b3182585f69c3864067a2a60377d5d46b (patch)
tree5a5f84db06e2fc897f2ff449e6cde6beb156102c /app-vim
parentapp-arch/bloscpack: drop old (diff)
downloadgentoo-b2216e2b3182585f69c3864067a2a60377d5d46b.tar.gz
gentoo-b2216e2b3182585f69c3864067a2a60377d5d46b.tar.bz2
gentoo-b2216e2b3182585f69c3864067a2a60377d5d46b.zip
app-vim/editorconfig-vim: Version bump to 1.0.0_beta
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/editorconfig-vim/Manifest1
-rw-r--r--app-vim/editorconfig-vim/editorconfig-vim-1.0.0_beta.ebuild39
-rw-r--r--app-vim/editorconfig-vim/files/editorconfig-vim-1.0.0_beta-wildcard-slash.patch22
3 files changed, 62 insertions, 0 deletions
diff --git a/app-vim/editorconfig-vim/Manifest b/app-vim/editorconfig-vim/Manifest
index c8518d7e7788..5e8f55996897 100644
--- a/app-vim/editorconfig-vim/Manifest
+++ b/app-vim/editorconfig-vim/Manifest
@@ -1 +1,2 @@
DIST editorconfig-vim-0.3.3.tar.gz 35395 BLAKE2B a7b65c1472024017dd408e5c4ac5048004d0bd55f44c7cfba49b5973cb445125ed89cc3d4363fb902a4c5fbb507f3ee5ed0ca48aece3fb6915e643bae0dbf70c SHA512 2dd968cf6bb162db8e6242ffb60cc61fb05a8042804b6b46b9f9cd35be968f83b473f04797e47c5cff11d7c052ff523bf8ba1d568992d44b72b97b54a81425a1
+DIST editorconfig-vim-1.0.0-beta.tar.gz 31519 BLAKE2B 2d5e8e55e8dccc0b45453b8da9ecad80867a84d1ea20146581886f793c093c201521a7d1d4451122ae441d30f58acec28d29aa20da9de737b5beb7f44d55c0ed SHA512 159e3ca32a7ffe71853ba62a14d0469310b81345b0e704dd6a9f42c56f6f6b9a3f63502ccabcf43a15443acf4acefdaf078063ae747f49315b89f5518d7f9816
diff --git a/app-vim/editorconfig-vim/editorconfig-vim-1.0.0_beta.ebuild b/app-vim/editorconfig-vim/editorconfig-vim-1.0.0_beta.ebuild
new file mode 100644
index 000000000000..5bf01abe3223
--- /dev/null
+++ b/app-vim/editorconfig-vim/editorconfig-vim-1.0.0_beta.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils vim-plugin
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="vim plugin: Support EditorConfig files "
+HOMEPAGE="https://editorconfig.org/"
+SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2 PSF-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN%-vim}.txt"
+
+PATCHES=(
+ "${FILESDIR}/editorconfig-vim-1.0.0_beta-wildcard-slash.patch"
+)
+
+src_prepare() {
+ default
+
+ rm LICENSE LICENSE.PSF \
+ mkzip.sh .editorconfig \
+ .git{ignore,modules} \
+ .{travis,appveyor}.yml || die
+}
+
+src_install() {
+ # we don't want to install the tests
+ rm -r tests || die
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/editorconfig-vim/files/editorconfig-vim-1.0.0_beta-wildcard-slash.patch b/app-vim/editorconfig-vim/files/editorconfig-vim-1.0.0_beta-wildcard-slash.patch
new file mode 100644
index 000000000000..d3dc81241a5e
--- /dev/null
+++ b/app-vim/editorconfig-vim/files/editorconfig-vim-1.0.0_beta-wildcard-slash.patch
@@ -0,0 +1,22 @@
+From 8b533e933f1e4904daae72e9d84f939cd18ffca8 Mon Sep 17 00:00:00 2001
+From: Chris White <cxwembedded@gmail.com>
+Date: Sat, 20 Jul 2019 13:14:57 -0400
+Subject: [PATCH] '?' wildcard does not match '/' (fixes #124)
+
+---
+ autoload/editorconfig_core/fnmatch.vim | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/autoload/editorconfig_core/fnmatch.vim b/autoload/editorconfig_core/fnmatch.vim
+index 14833bf0..6f60db5d 100644
+--- a/autoload/editorconfig_core/fnmatch.vim
++++ b/autoload/editorconfig_core/fnmatch.vim
+@@ -199,7 +199,7 @@ function! editorconfig_core#fnmatch#translate(pat, ...)
+ endif
+
+ elseif l:current_char ==# '?'
+- let l:result .= '\_.'
++ let l:result .= '\_[^/]'
+
+ elseif l:current_char ==# '['
+ if l:in_brackets