summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-12-13 09:25:51 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-12-13 09:26:30 +0100
commitc94c53d491c9f5a9d6af46f6b96946885fe44198 (patch)
tree1de7c6676bc16c90c8c82d7f5b50e674121af254 /app-vim/vimtex
parentsys-kernel/vanilla-sources: Automated version bump to {4.19.89,5.3.16,5.4.3} ... (diff)
downloadgentoo-c94c53d491c9f5a9d6af46f6b96946885fe44198.tar.gz
gentoo-c94c53d491c9f5a9d6af46f6b96946885fe44198.tar.bz2
gentoo-c94c53d491c9f5a9d6af46f6b96946885fe44198.zip
app-vim/vimtex: remove bad dependencies.
Closes: https://bugs.gentoo.org/688584 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim/vimtex')
-rw-r--r--app-vim/vimtex/vimtex-20180324-r1.ebuild33
-rw-r--r--app-vim/vimtex/vimtex-99999999.ebuild7
2 files changed, 35 insertions, 5 deletions
diff --git a/app-vim/vimtex/vimtex-20180324-r1.ebuild b/app-vim/vimtex/vimtex-20180324-r1.ebuild
new file mode 100644
index 000000000000..fc0060ecefde
--- /dev/null
+++ b/app-vim/vimtex/vimtex-20180324-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
+ SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r *.md media test || die
+}
diff --git a/app-vim/vimtex/vimtex-99999999.ebuild b/app-vim/vimtex/vimtex-99999999.ebuild
index d4031034c014..fc0060ecefde 100644
--- a/app-vim/vimtex/vimtex-99999999.ebuild
+++ b/app-vim/vimtex/vimtex-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,10 +23,7 @@ VIM_PLUGIN_HELPFILES="${PN}"
RDEPEND="
!app-vim/vim-latex
- !app-vim/automatictexplugin
- virtual/latex-base
- dev-tex/latexmk
-"
+ !app-vim/automatictexplugin"
src_prepare() {
default