summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2019-05-22 08:33:23 -0600
committerDenis Dupeyron <calchan@gentoo.org>2019-05-22 08:35:31 -0600
commit17a1ffa7f31d8a0b47fa40ab01d2f7e7a1cb2760 (patch)
treec5e6d68463f4304a81fb8fe91f9021acf4c6da35 /app-vim/vim-go/vim-go-1.20.ebuild
parentprofiles: stable-mask iwd flag on connman until iwd is stable (diff)
downloadgentoo-17a1ffa7f31d8a0b47fa40ab01d2f7e7a1cb2760.tar.gz
gentoo-17a1ffa7f31d8a0b47fa40ab01d2f7e7a1cb2760.tar.bz2
gentoo-17a1ffa7f31d8a0b47fa40ab01d2f7e7a1cb2760.zip
app-vim/vim-go: bump to 1.20
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'app-vim/vim-go/vim-go-1.20.ebuild')
-rw-r--r--app-vim/vim-go/vim-go-1.20.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/vim-go/vim-go-1.20.ebuild b/app-vim/vim-go/vim-go-1.20.ebuild
new file mode 100644
index 000000000000..3a6740617589
--- /dev/null
+++ b/app-vim/vim-go/vim-go-1.20.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RESTRICT="test"
+
+src_compile() {
+ # safely skip `make test` triggered by `make` as it runs `go get` commands
+ # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+ :;
+}