summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/pyclewn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/pyclewn')
-rw-r--r--app-vim/pyclewn/Manifest2
-rw-r--r--app-vim/pyclewn/metadata.xml12
-rw-r--r--app-vim/pyclewn/pyclewn-2.0.1.ebuild47
-rw-r--r--app-vim/pyclewn/pyclewn-2.1.ebuild47
4 files changed, 108 insertions, 0 deletions
diff --git a/app-vim/pyclewn/Manifest b/app-vim/pyclewn/Manifest
new file mode 100644
index 000000000000..67c4fac9c0de
--- /dev/null
+++ b/app-vim/pyclewn/Manifest
@@ -0,0 +1,2 @@
+DIST pyclewn-2.0.1.tar.gz 124914 SHA256 15549d7375299c286abc3da9cb0942cc834f354715aa5464f8c68c104cc67621 SHA512 996acbedbb7922109925f188efba4c71e83f1823c029f92dc00bb21449f024232ef55df0c74a9fd4bfa7229523ed9ad4301aa9dbb8a3c20424082fc6939f63db WHIRLPOOL e92bab273982783f61c0bdfe464673be26225c02ce8ba14a0d7e1d9088167f3c48cc07247b83e36b5d98bdc6e314f76c828d3de1068b5ca4633149bc8aa0be8d
+DIST pyclewn-2.1.tar.gz 129697 SHA256 4e6dccb6afa07e34202cc8cba4fc63a53d432b2dbc3f1a08c1945bbdd2a2a855 SHA512 346b98a9e37957a5bf97b8901247f56fa8e38bddac38727867773cf4e78e555d6a85848c4c400d1faf1159ba61122cfd4931c95a67e3b2abdfaae7996beb4f1b WHIRLPOOL ecf35c8e7ef0e60f4297dc3375d31023f26aea645ec95193c5c4ec808f4d8c973524405d14c15317ceb03a5974ab079ee545ecc987d2ed99f4681dc39133df3a
diff --git a/app-vim/pyclewn/metadata.xml b/app-vim/pyclewn/metadata.xml
new file mode 100644
index 000000000000..f73ba1ba3999
--- /dev/null
+++ b/app-vim/pyclewn/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyclewn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/pyclewn/pyclewn-2.0.1.ebuild b/app-vim/pyclewn/pyclewn-2.0.1.ebuild
new file mode 100644
index 000000000000..e1cc815f98cf
--- /dev/null
+++ b/app-vim/pyclewn/pyclewn-2.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit eutils vim-plugin distutils-r1
+
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="|| (
+ >=app-editors/vim-7.3[${PYTHON_USEDEP}]
+ >=app-editors/gvim-7.3[netbeans,${PYTHON_USEDEP}]
+)"
+DEPEND="${CDEPEND}
+ app-arch/vimball
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
+"
+
+SLOT="0"
+
+#Completely broken (runs vim), disable for now
+#python_test() {
+# esetup.py test
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ optfeature "C/C++ debugging" sys-devel/gdb
+ optfeature "Python debugging" dev-python/pdb-clone
+}
diff --git a/app-vim/pyclewn/pyclewn-2.1.ebuild b/app-vim/pyclewn/pyclewn-2.1.ebuild
new file mode 100644
index 000000000000..e1cc815f98cf
--- /dev/null
+++ b/app-vim/pyclewn/pyclewn-2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit eutils vim-plugin distutils-r1
+
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="|| (
+ >=app-editors/vim-7.3[${PYTHON_USEDEP}]
+ >=app-editors/gvim-7.3[netbeans,${PYTHON_USEDEP}]
+)"
+DEPEND="${CDEPEND}
+ app-arch/vimball
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
+"
+
+SLOT="0"
+
+#Completely broken (runs vim), disable for now
+#python_test() {
+# esetup.py test
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ optfeature "C/C++ debugging" sys-devel/gdb
+ optfeature "Python debugging" dev-python/pdb-clone
+}