summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/minibufexpl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/minibufexpl')
-rw-r--r--app-vim/minibufexpl/Manifest3
-rw-r--r--app-vim/minibufexpl/metadata.xml8
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.4.3.ebuild37
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.4.4.ebuild22
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.5.2.ebuild23
5 files changed, 93 insertions, 0 deletions
diff --git a/app-vim/minibufexpl/Manifest b/app-vim/minibufexpl/Manifest
new file mode 100644
index 000000000000..affd15e53b09
--- /dev/null
+++ b/app-vim/minibufexpl/Manifest
@@ -0,0 +1,3 @@
+DIST minibufexpl-6.4.3.tar.gz 27907 SHA256 f9a9bb217e0f64faf146ee2ec4f8ee74e93199f564f5891d750d8f357b09d176 SHA512 631013654bd69479cd119b7f112ab1dd28b94fd3fdf832b2951d6a82e9d9b00a2d180bc1ccaee9abd0e855a17db3cadc0937b3418e8c4313d5f49ac06bd8beff WHIRLPOOL 6ffb447454b85a74592e2b8c1d70754c527b9aae7d793ecc4c56af8c633f929320c1431b70c02fd810eb0a6a7496798dfb5d5a24c9227fee43367bb7fb1fc644
+DIST minibufexpl-6.4.4.tar.gz 27273 SHA256 f4f404273607962a769f34f8057cf36c9547e5db27eb8400a04c11742c5fdafc SHA512 e48151483021860db1cd023d65899216146ee79ebbcd30a2514901c936f7cbc41abc7b023f65a839ceb762f0e15cd80ef2548540a239add9b093ef25ce9145a8 WHIRLPOOL 0e75d9a6253a3b53209380226c11bbb44bd184f435e45d4f4c97443bb52b9ef8d4dd5ad974c30fea77b14b46ce7e0d6948a37af4ab63c17c3807db52b16e9b45
+DIST minibufexpl-6.5.2.tar.gz 32119 SHA256 9638336d41a3550bb82c5b911ac23178d1df72438c3f140450fbd3d4a7f2d148 SHA512 325fb58b025392c5484574c4988ec95eb7374a10b67a4abe28857a0ae8d768316ef4d477b51bf442ffc1bcfb5f68dfd0c924731291b155192731055fed3569d1 WHIRLPOOL 66bfc0fe5787f45cec84c75479d648a62a02cb1e3922e77c4c844f889a3388732bec8775fdd5636de83af91ade33cba8e22f8e5f77961d32c004d819f0c8e0b7
diff --git a/app-vim/minibufexpl/metadata.xml b/app-vim/minibufexpl/metadata.xml
new file mode 100644
index 000000000000..7b111b50bc45
--- /dev/null
+++ b/app-vim/minibufexpl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">fholgado/minibufexpl.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/minibufexpl/minibufexpl-6.4.3.ebuild b/app-vim/minibufexpl/minibufexpl-6.4.3.ebuild
new file mode 100644
index 000000000000..6b53d2fe1987
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt
+
+ # Discard unwanted files
+ rm .gitignore README project.html || die
+}
diff --git a/app-vim/minibufexpl/minibufexpl-6.4.4.ebuild b/app-vim/minibufexpl/minibufexpl-6.4.4.ebuild
new file mode 100644
index 000000000000..6a1280bbe315
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.4.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin vcs-snapshot
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="bufexplorer.vim"
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # discard unwanted files
+ rm .gitignore readme.markdown project.html || die
+}
diff --git a/app-vim/minibufexpl/minibufexpl-6.5.2.ebuild b/app-vim/minibufexpl/minibufexpl-6.5.2.ebuild
new file mode 100644
index 000000000000..7db046c4f738
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="bufexplorer.vim"
+KEYWORDS="amd64 ~mips ppc x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ # discard unwanted files
+ rm .gitignore README.md || die
+}