summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-28 18:13:03 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-28 18:15:24 -0400
commit494dfc564cfb3039177eacaac02627b2e511019e (patch)
tree9f5861d02d460f47c02ec6b89e7da0dda80dea54 /app-vim/gundo/gundo-2.6.2.ebuild
parentdev-java/icedtea-bin: Remove vulnerable 3.3.0 wrt bug #618874 (diff)
downloadgentoo-494dfc564cfb3039177eacaac02627b2e511019e.tar.gz
gentoo-494dfc564cfb3039177eacaac02627b2e511019e.tar.bz2
gentoo-494dfc564cfb3039177eacaac02627b2e511019e.zip
app-vim/gundo: version bump to 2.6.2
And update HOMEPAGE for old version as well.
Diffstat (limited to 'app-vim/gundo/gundo-2.6.2.ebuild')
-rw-r--r--app-vim/gundo/gundo-2.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/gundo/gundo-2.6.2.ebuild b/app-vim/gundo/gundo-2.6.2.ebuild
new file mode 100644
index 000000000000..28f68459e8e2
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
+SRC_URI="https://bitbucket.org/sjl/gundo.vim/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+ default
+}