summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-09-21 05:06:11 -0400
committerTim Harder <radhermit@gentoo.org>2019-01-04 13:30:30 -0600
commita21a040144342e5e7c3b73d87d43ea0a804b57ee (patch)
tree56e0def71272fb32ea567bfc2ef753c46328b997 /app-vim/gitgutter
parentdev-lang/ocaml: use https for HOMEPAGE (diff)
downloadgentoo-a21a040144342e5e7c3b73d87d43ea0a804b57ee.tar.gz
gentoo-a21a040144342e5e7c3b73d87d43ea0a804b57ee.tar.bz2
gentoo-a21a040144342e5e7c3b73d87d43ea0a804b57ee.zip
app-vim/gitgutter: version bump to 20180815
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/gitgutter')
-rw-r--r--app-vim/gitgutter/Manifest1
-rw-r--r--app-vim/gitgutter/gitgutter-20180815.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/gitgutter/Manifest b/app-vim/gitgutter/Manifest
index c139b6e1dc28..ca747d9a7a09 100644
--- a/app-vim/gitgutter/Manifest
+++ b/app-vim/gitgutter/Manifest
@@ -1,2 +1,3 @@
DIST gitgutter-20171101.tar.gz 43534 BLAKE2B cb0b935c1b2d16a50bbecc73f4f8c657a9087bef56bef36af8ff52a7ff09d39293296eaf49507015eaeac7f4faba2a26a09a49296c28237029110068cb9f6048 SHA512 24d8ad740931df17c2c67e2a2a13e3bba7c1205ba5543f5c11353e639876f4a54e69170dc0a946660ee2e3a23a110c90f4195fa9a1ddfff19163f00d88528219
DIST gitgutter-20180316.tar.gz 46344 BLAKE2B f981753a0f8d066b7cb5c16c49cfdd1a1aac1c6623b4645b8b1abd5719470ac181e09c8b736f8b8a14e6098b60cb8f97b114dc5c2a587b6d1875fcf27b4b12cf SHA512 15873b2cccc49f8aec9de312efedc615d6fa822b45ca8ce53cc6cc878fcaf3a6ab3f02eb5d082ff329528cce1b48358846b0aba3f9d3bc8aadd29aa57d3b1a30
+DIST gitgutter-20180815.tar.gz 46741 BLAKE2B 85189390a2d8c5feaf8d2fabfd2c72bf79954fd1e9f2c3ffeca748e84caf13924f71ef5837ab62aef0ae003a01304305e73bbcb12dca27294c8164e960249fec SHA512 b6d3bd0f779d9afbd38df33888ab3ee0f1d8d10de0a6c5c6766f7f73a292cdd589a6774faa2871877075f6cedd29f14bba07c9a769d706e0e67d8817db86cfaa
diff --git a/app-vim/gitgutter/gitgutter-20180815.ebuild b/app-vim/gitgutter/gitgutter-20180815.ebuild
new file mode 100644
index 000000000000..38fbbde158d1
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20180815.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="50a7062909d91a290fae04219887b1b45f3138db"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm LICENCE README* screenshot.png unplace.vim || die
+ rm -r test || die
+}