summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/dhcpd-syntax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/dhcpd-syntax')
-rw-r--r--app-vim/dhcpd-syntax/Manifest1
-rw-r--r--app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild20
-rw-r--r--app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch12
-rw-r--r--app-vim/dhcpd-syntax/metadata.xml10
4 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/dhcpd-syntax/Manifest b/app-vim/dhcpd-syntax/Manifest
new file mode 100644
index 000000000000..b05c0a7dad3e
--- /dev/null
+++ b/app-vim/dhcpd-syntax/Manifest
@@ -0,0 +1 @@
+DIST dhcpd-syntax-20030825.tar.bz2 2761 SHA256 4f25a880a6505f33c6235b07851ab9eefc0c336500630d6fc80347ecde1a281d SHA512 97c1706e0ab2c89ee20618ae0c854347f8674a3008a5c4414aacb78e984e35b0eb6eeb5f641363ed6601ceeac0c794577d518658db9200c7391871ffae5341bc WHIRLPOOL 5d7dd6218ac881d17ce0351ba4c116587e5aab6faeb64eaca5e7cdf87be0b539128e9e203011921c17a74150efef204bd5b1c3f38f7fdba452b3355fac2aaa7a
diff --git a/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild
new file mode 100644
index 000000000000..d007d567973b
--- /dev/null
+++ b/app-vim/dhcpd-syntax/dhcpd-syntax-20030825.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: syntax highlighting for dhcpd.conf"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=744"
+LICENSE="vim"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for dhcpd.conf files."
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-multiple-addresses.patch
+}
diff --git a/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
new file mode 100644
index 000000000000..22eaa8236795
--- /dev/null
+++ b/app-vim/dhcpd-syntax/files/dhcpd-syntax-20030825-multiple-addresses.patch
@@ -0,0 +1,12 @@
+--- syntax/dhcpd.vim.orig 2005-03-24 16:41:59.755564944 +0000
++++ syntax/dhcpd.vim 2005-03-24 16:42:15.894111512 +0000
+@@ -33,7 +33,7 @@
+ " Base constructs {{{
+ syn match dhcpdString +"[^"]*"+
+ syn match dhcpdDecNumber "\<-\?\d\+\(;\|\s\|$\)"
+-syn match dhcpdIPv4 "\<\(\d\{1,3}\.\)\{3}\d\{1,3}\(;\|\s\|$\)"
++syn match dhcpdIPv4 "\<\(\d\{1,3}\.\)\{3}\d\{1,3}\(;\|\s\|,\|$\)"
+ syn match dhcpdMAC "\<\(\x\x\?:\)\{5}\x\x\?\(;\|\s\|$\)"
+ syn match dhcpdDate "\<[0-6]\s\d\{4}/\d\d/\d\d/\s\d\d:\d\d:\d\d\(;\|\s\|$\)"
+ """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""" }}}
+
diff --git a/app-vim/dhcpd-syntax/metadata.xml b/app-vim/dhcpd-syntax/metadata.xml
new file mode 100644
index 000000000000..d0d2d472331a
--- /dev/null
+++ b/app-vim/dhcpd-syntax/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <longdescription lang="en">
+ This package provides Vim syntax highlighting for dhcpd configuration
+ files, and automatic filetype detection for these files based upon
+ filename.
+ </longdescription>
+</pkgmetadata>