summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-23 20:40:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-23 20:49:36 +0200
commitebb1f06afdaddc59825847948e1237fdc4421678 (patch)
tree135268a979c1b2b3c89bfbecb646be385ab039af /app-text
parentapp-misc/jaq: add 1.4.0 (diff)
downloadgentoo-ebb1f06afdaddc59825847948e1237fdc4421678.tar.gz
gentoo-ebb1f06afdaddc59825847948e1237fdc4421678.tar.bz2
gentoo-ebb1f06afdaddc59825847948e1237fdc4421678.zip
app-text/kbibtex: Fix build w/ ICU-75
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kbibtex/files/kbibtex-0.10.0-cxx17.patch11
-rw-r--r--app-text/kbibtex/kbibtex-0.10.0.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/app-text/kbibtex/files/kbibtex-0.10.0-cxx17.patch b/app-text/kbibtex/files/kbibtex-0.10.0-cxx17.patch
new file mode 100644
index 000000000000..33fb8ebb4542
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.10.0-cxx17.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -10,7 +10,7 @@
+ LANGUAGES CXX
+ )
+
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 17)
+ set(QT_MIN_VERSION 5.9.0)
+ # Somewhat arbitrary chosen version number ...
+ set(KF5_MIN_VERSION 5.51)
diff --git a/app-text/kbibtex/kbibtex-0.10.0.ebuild b/app-text/kbibtex/kbibtex-0.10.0.ebuild
index 11a10b600ce5..aa8b9929c2d5 100644
--- a/app-text/kbibtex/kbibtex-0.10.0.ebuild
+++ b/app-text/kbibtex/kbibtex-0.10.0.ebuild
@@ -60,6 +60,8 @@ DEPEND="${COMMON_DEPEND}
>=dev-qt/qtconcurrent-${QTMIN}:5
"
+PATCHES=( "${FILESDIR}"/${P}-cxx17.patch )
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebKitWidgets=ON