summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-07 21:56:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-07 21:56:27 +0300
commit9d381821a0d9521e0a181bdd0dc7f9ac682e5020 (patch)
tree95a7ad7af2f7f0e4db538e7d5a91eff966b695cc /app-text
parentdev-vcs/breezy: add 3.3.0, enable py3.11, restrict tests (diff)
downloadgentoo-9d381821a0d9521e0a181bdd0dc7f9ac682e5020.tar.gz
gentoo-9d381821a0d9521e0a181bdd0dc7f9ac682e5020.tar.bz2
gentoo-9d381821a0d9521e0a181bdd0dc7f9ac682e5020.zip
app-text/sigil: remove IUSE="system-mathjax"
It currently depends on mathjax3, which might take sometime to bump the current mathjax ebuild (consumers using v2 instead of v3 and such). For now I'll remove the useflag, and readd it in the future when ::gentoo's mathjax is v3. Closes: https://bugs.gentoo.org/907716 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sigil/metadata.xml1
-rw-r--r--app-text/sigil/sigil-1.9.30.ebuild5
2 files changed, 2 insertions, 4 deletions
diff --git a/app-text/sigil/metadata.xml b/app-text/sigil/metadata.xml
index 16a802d7daa4..4daa9a331609 100644
--- a/app-text/sigil/metadata.xml
+++ b/app-text/sigil/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="plugins">Installed needed Python packages for using Sigil plugins</flag>
- <flag name="system-mathjax">Use the system-wide <pkg>dev-libs/mathjax</pkg> instead of bundled</flag>
</use>
<upstream>
<remote-id type="github">Sigil-Ebook/Sigil</remote-id>
diff --git a/app-text/sigil/sigil-1.9.30.ebuild b/app-text/sigil/sigil-1.9.30.ebuild
index 621537704a6e..681e2613d8dd 100644
--- a/app-text/sigil/sigil-1.9.30.ebuild
+++ b/app-text/sigil/sigil-1.9.30.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/${P^}"
LICENSE="GPL-3+ Apache-2.0"
SLOT="0"
KEYWORDS="amd64"
-IUSE="+plugins system-mathjax"
+IUSE="+plugins"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
@@ -41,7 +41,6 @@ RDEPEND="
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/regex[${PYTHON_USEDEP}]') )
- system-mathjax? ( dev-libs/mathjax )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -63,7 +62,7 @@ src_configure() {
-DUSE_SYSTEM_LIBS=1
-DUSE_QT6=0
)
- use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
+ # use system-mathjax && mycmakeargs+=( -DMATHJAX3_DIR="${EPREFIX}"/usr/share/mathjax )
cmake_src_configure
}