summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-10-14 22:43:11 +0300
committerSam James <sam@gentoo.org>2024-12-01 12:42:53 +0000
commit86de2ff1a7f3c704cc3362c7e50881ce6f728f0f (patch)
tree9b8e865d695f4415bc8fde019c9babf376b016c4 /app-text
parentwww-apps/redmine: drop 5.0.6, 5.1.0 (diff)
downloadgentoo-86de2ff1a7f3c704cc3362c7e50881ce6f728f0f.tar.gz
gentoo-86de2ff1a7f3c704cc3362c7e50881ce6f728f0f.tar.bz2
gentoo-86de2ff1a7f3c704cc3362c7e50881ce6f728f0f.zip
app-text/cmark: add 0.31.1
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.31.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index 9405f0d6d887..4d3acdd63f8c 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1,2 +1,3 @@
DIST cmark-0.30.3.tar.gz 246916 BLAKE2B b63027e1a7d6db21c3b1bfc89deaebb202972cf65b3ddc51f20d6cb2dacfb6724dffd226f3cace1b25dda2cd87bdb201b82779bd7a6068c5f9751513bda226ae SHA512 27383bfef95ae1390c26aff0dd2cbca33704e7d20116bf29da4695d2c9a4146b86daba0da1e91bdb9eab95671702f885e832b3d31d51601731f1dc630df5237b
DIST cmark-0.31.0.tar.gz 251922 BLAKE2B 9532255066cd21e99de430787f261b3014c4d270e8243aa258bb9c90cf2ccfd7138dcff2e15f576cc28ee6b6b7901c0f321f5ead6a9202e06b4223288f326897 SHA512 768d456147cb8f5cf36e8122213ad053098201e118109a316518a6a5e721ac94f62af29abe1e69120c84bdc227a5c320803ea2cf320c6d9a719d62909b6533bd
+DIST cmark-0.31.1.tar.gz 264170 BLAKE2B c1de1cf035ff5c706455889413c8cfdaa4b5da39a333d21ed77e2091d1a2f5ef9c90c34100c18be62426aea68c2d5ce157719964a761312f7e4b11e05dae0024 SHA512 3b4f8b47d8ea270078ab986aa22fc32b227786459bd33c7225aac578d8dd014e3d8788a6add60ea10571fdb4c7dc6a1ece960815a02f04f153b1775c73ccff8f
diff --git a/app-text/cmark/cmark-0.31.1.ebuild b/app-text/cmark/cmark-0.31.1.ebuild
new file mode 100644
index 000000000000..ae89bcc8e095
--- /dev/null
+++ b/app-text/cmark/cmark-0.31.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0.31.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}/cmark-0.31.0_fix_api_test.patch"
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}