summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-07-05 15:44:03 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-07-05 15:44:52 +0200
commit48f776e11b0a98cbe2eace43951921733787127d (patch)
treed0b422c148c108307bdb1f4fa27f462ba2fcb9f1 /app-text
parentdev-java/gradle-bin: add 7.1.1 (diff)
downloadgentoo-48f776e11b0a98cbe2eace43951921733787127d.tar.gz
gentoo-48f776e11b0a98cbe2eace43951921733787127d.tar.bz2
gentoo-48f776e11b0a98cbe2eace43951921733787127d.zip
app-text/kramdown-rfc2629: add 1.4.19
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kramdown-rfc2629/Manifest1
-rw-r--r--app-text/kramdown-rfc2629/kramdown-rfc2629-1.4.19.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/kramdown-rfc2629/Manifest b/app-text/kramdown-rfc2629/Manifest
index 841270930708..3ebc1fcaa0e6 100644
--- a/app-text/kramdown-rfc2629/Manifest
+++ b/app-text/kramdown-rfc2629/Manifest
@@ -1 +1,2 @@
DIST kramdown-rfc2629-1.4.18.gem 47104 BLAKE2B 692071c3182703848a6a6629454e06487919657ec0a0fdf33a7a4ef53421751fad81f67167c33fe0d9a5397bce270c660bf9091862739ecb42dc9adceefb6c50 SHA512 e1bc0537ef936f3519ecbebad055f3cbd136c117a62e84878fdb5a63ad224e2256dfe51285abc84345e6e7322dc3f131c9577d7cf3340c32d224451dec27b323
+DIST kramdown-rfc2629-1.4.19.gem 47104 BLAKE2B a967987f34b0af0bff964488d640a8ca830e55b8a1955442896ed0bebf2cd4d9b902699e1347bd81d82a1b10e085ad2f2827968ff62e96cc4ea7f023f8336af1 SHA512 4843690fe10ae02d90a4dde9ade086308b8081155bd6fea1d83c38563cba1c2d447e337f658666fabb57ca9f85b5f4d5687db2503b0b28b5718b978b1db2714a
diff --git a/app-text/kramdown-rfc2629/kramdown-rfc2629-1.4.19.ebuild b/app-text/kramdown-rfc2629/kramdown-rfc2629-1.4.19.ebuild
new file mode 100644
index 000000000000..c3777b12f31c
--- /dev/null
+++ b/app-text/kramdown-rfc2629/kramdown-rfc2629-1.4.19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An RFC2629 (XML2RFC) backend for Thomas Leitner's kramdown markdown parser"
+HOMEPAGE="https://github.com/cabo/kramdown-rfc2629"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ >=dev-ruby/kramdown-2.3.0
+ >=dev-ruby/certified-1.0.0
+ >=dev-ruby/json-2.0.0
+"
+
+all_ruby_prepare() {
+ sed -i 's/json_pure/json/' ../metadata || die
+}