summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-22 18:30:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-22 18:45:49 +0200
commit2e53d380fb1b13ce3fa5b0e3908ce43d27c8a3eb (patch)
tree714ab06aaacefeac5131bea019f7734f9f69d9b9 /app-text
parentwww-apps/sonarr-bin: drop 4.0.4.1668 (diff)
downloadgentoo-2e53d380fb1b13ce3fa5b0e3908ce43d27c8a3eb.tar.gz
gentoo-2e53d380fb1b13ce3fa5b0e3908ce43d27c8a3eb.tar.bz2
gentoo-2e53d380fb1b13ce3fa5b0e3908ce43d27c8a3eb.zip
app-text/libmspub: Fix build w/ ICU-75, update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/932494 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libmspub/libmspub-0.1.4.ebuild16
-rw-r--r--app-text/libmspub/libmspub-9999.ebuild18
2 files changed, 17 insertions, 17 deletions
diff --git a/app-text/libmspub/libmspub-0.1.4.ebuild b/app-text/libmspub/libmspub-0.1.4.ebuild
index dfb60ca4296b..78d0df1963cf 100644
--- a/app-text/libmspub/libmspub-0.1.4.ebuild
+++ b/app-text/libmspub/libmspub-0.1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic
@@ -19,18 +19,18 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc static-libs"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-text/doxygen )
-"
RDEPEND="
dev-libs/icu:=
dev-libs/librevenge
sys-libs/zlib
"
DEPEND="${RDEPEND}
- dev-libs/boost
dev-build/libtool
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
"
PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
@@ -44,8 +44,8 @@ src_prepare() {
}
src_configure() {
- # bug 619044
- append-cxxflags -std=c++14
+ # bug 619044, 932494
+ append-cxxflags -std=c++17
local myeconfargs=(
--disable-werror
diff --git a/app-text/libmspub/libmspub-9999.ebuild b/app-text/libmspub/libmspub-9999.ebuild
index 81c8ae0ea3ec..f42bebd2d32f 100644
--- a/app-text/libmspub/libmspub-9999.ebuild
+++ b/app-text/libmspub/libmspub-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic
-if [[ ${PV} = *9999 ]]; then
+if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
inherit git-r3
else
@@ -19,18 +19,18 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc static-libs"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-text/doxygen )
-"
RDEPEND="
dev-libs/icu:=
dev-libs/librevenge
sys-libs/zlib
"
DEPEND="${RDEPEND}
- dev-libs/boost
dev-build/libtool
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
"
src_prepare() {
@@ -42,8 +42,8 @@ src_prepare() {
}
src_configure() {
- # bug 619044
- append-cxxflags -std=c++14
+ # bug 619044, 932494
+ append-cxxflags -std=c++17
local myeconfargs=(
--disable-werror