summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/zathura-ps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/zathura-ps')
-rw-r--r--app-text/zathura-ps/Manifest1
-rw-r--r--app-text/zathura-ps/metadata.xml25
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.2.ebuild50
-rw-r--r--app-text/zathura-ps/zathura-ps-9999.ebuild50
4 files changed, 126 insertions, 0 deletions
diff --git a/app-text/zathura-ps/Manifest b/app-text/zathura-ps/Manifest
new file mode 100644
index 000000000000..43c683774115
--- /dev/null
+++ b/app-text/zathura-ps/Manifest
@@ -0,0 +1 @@
+DIST zathura-ps-0.2.2.tar.gz 5793 SHA256 e6546261db03b0b6b6499a8e109dc9ff3b8eb8b154ce45f5c6284c1e76d1d7a8 SHA512 4cedd614127b995ad834d5913dd5d9b3dff6172ac31cf42e8d43941815ac03a4872f41d7766c325f435feffa63364c9c377f760cd0540d2f36753e7df1c4c49e WHIRLPOOL 246f7cede9096474efab0c1b4f25bbd4b908eeb1a3a995d390939c02b79ca2adcce86582fd4129189b20e9028f6c0e9079c674cc1beebc59844b8b3d5597b76c
diff --git a/app-text/zathura-ps/metadata.xml b/app-text/zathura-ps/metadata.xml
new file mode 100644
index 000000000000..e21ab424480f
--- /dev/null
+++ b/app-text/zathura-ps/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mlq@pwmt.org</email>
+ <name>Moritz Lipp</name>
+ </maintainer>
+ <maintainer status="active">
+ <email>sebastian+dev@ramacher.at</email>
+ <name>Sebastian Ramacher</name>
+ </maintainer>
+ <changelog>http://pwmt.org/projects/zathura/download/</changelog>
+ <doc lang="en">http://pwmt.org/projects/zathura/</doc>
+ <bugs-to>http://bugs.pwmt.org/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/zathura-ps/zathura-ps-0.2.2.ebuild b/app-text/zathura-ps/zathura-ps-0.2.2.ebuild
new file mode 100644
index 000000000000..c34c4ce31c58
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-0.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+else
+KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND=">=app-text/libspectre-0.2.6:=
+ >=app-text/zathura-0.2.7
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}
diff --git a/app-text/zathura-ps/zathura-ps-9999.ebuild b/app-text/zathura-ps/zathura-ps-9999.ebuild
new file mode 100644
index 000000000000..a1fa8e62d57d
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+else
+KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND=">=app-text/libspectre-0.2.6:=
+ >=app-text/zathura-0.2.7
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}