summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xlhtml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xlhtml')
-rw-r--r--app-text/xlhtml/Manifest2
-rw-r--r--app-text/xlhtml/metadata.xml7
-rw-r--r--app-text/xlhtml/xlhtml-0.5.1_p6.ebuild45
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/xlhtml/Manifest b/app-text/xlhtml/Manifest
new file mode 100644
index 000000000000..632aa8050ef6
--- /dev/null
+++ b/app-text/xlhtml/Manifest
@@ -0,0 +1,2 @@
+DIST xlhtml_0.5.1-6.diff.gz 119282 SHA256 afaf050c6b26bdd743e2e1b90963d6ae2bc8ddb8b0add11d397e0062cfba868b SHA512 f1f4bba58858e6033f164e689333904887b7cd60bf082e2247e7fe0c54f3737e72aff6590deefd1d8a04d4b25d27631664594c50c9cc4bbdc8c9b20c6ccce7bd WHIRLPOOL 94ab67245d4e1ba26d86663ea5d60eeb5e13ee455a64cf448c0f74716a30a7e98ac8dbbde2c0ad8ad44ef01ab203943bbd3707419e2f33c55097cc61d8e36cba
+DIST xlhtml_0.5.1.orig.tar.gz 263933 SHA256 81fb9e786bb7c440423566b0aa71d7395685dd4566a8388a4d89ee6a8a5cd873 SHA512 9ac1cafd4496293cbc5ca9109a8d467fab6dd24c1daa91754b7f49502e2607272292b8bb9ed876b21fe1b287ef3293a0f6c5882c18a18fd715137c27d63f9f01 WHIRLPOOL ef7d36599bc5819755f2c5f37e42faa266d6eb5c2211632973c8d0dc82fe21add4289bb7012d8a02684652c713dd59e1d181407e854cacc2da2fe1e7f0605705
diff --git a/app-text/xlhtml/metadata.xml b/app-text/xlhtml/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/app-text/xlhtml/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
new file mode 100644
index 000000000000..0600f6bf95ab
--- /dev/null
+++ b/app-text/xlhtml/xlhtml-0.5.1_p6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PV=${PV/_p*/}
+DEB_PR=${PV/*_p/}
+
+DESCRIPTION="Convert MS Excel and Powerpoint files to HTML"
+HOMEPAGE="http://chicago.sourceforge.net/xlhtml/ http://packages.debian.org/etch/xlhtml/"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${MY_PV}-${DEB_PR}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ ecvs_clean
+ epatch "${WORKDIR}"/${PN}_${MY_PV}-${DEB_PR}.diff
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ docinto cole
+ dodoc cole/{AUTHORS,COPYING,NEWS,ChangeLog,THANKS,TODO}
+
+ docinto ppthtml
+ dodoc ppthtml/{ChangeLog,README,THANKS}
+
+ docinto xlhtml
+ dodoc -r xlhtml/{ChangeLog,README,THANKS,TODO,contrib}
+}