summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-08 18:07:14 +0100
committerSam James <sam@gentoo.org>2024-09-08 18:15:47 +0100
commit8ecfe46de9bc0a54428b42486c7086f7af42beb7 (patch)
treee12210f43321a33bd300cdee2faaaf5bf674ecc9 /app-text/xapian-omega
parentdev-libs/xapian: add 1.4.26 (diff)
downloadgentoo-8ecfe46de9bc0a54428b42486c7086f7af42beb7.tar.gz
gentoo-8ecfe46de9bc0a54428b42486c7086f7af42beb7.tar.bz2
gentoo-8ecfe46de9bc0a54428b42486c7086f7af42beb7.zip
app-text/xapian-omega: add 1.4.26
Bug: https://bugs.gentoo.org/937465 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.26.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 710493a26075..4824a9161da0 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -1 +1,2 @@
DIST xapian-omega-1.4.25.tar.xz 578904 BLAKE2B d0bb62741f7c58d1398a4dc8bca3de2b385094fb8126a4e36f424cb09964ac350709bf6dabc38d8d7ebf5f3fcd213d2a444d8e5e5cc52c6353f1c72fc7eebd72 SHA512 2b0d855baaaabbf6da1b86d61f0d3e85d5fb62d1b7d04738a7e15758d0042b9e22f80f0aa273b9a9a21b04dff579c561280e44f2a69a0c0d4f270cb0fbcef169
+DIST xapian-omega-1.4.26.tar.xz 583808 BLAKE2B b5a2779ed5fb4f729e8aa3bd309f09d9867ba8d646121f4f577a5208e1fae605f18c7ecfbcba2fdb8a7ddd54de7f0eb8b8299f0f7d26b272ccdf417fbbf5b2a6 SHA512 576eb82fa972bd0db46c8422695930235ab75677104ec32765421b0e1e813d0c40d3bdace3d88cc66fd28680fbcb75a3adcd808617ae4d7d48e35e0556f908c3
diff --git a/app-text/xapian-omega/xapian-omega-1.4.26.ebuild b/app-text/xapian-omega/xapian-omega-1.4.26.ebuild
new file mode 100644
index 000000000000..1e0983f89c26
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.26.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+HOMEPAGE="https://xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libpcre2:=
+ ~dev-libs/xapian-${PV}:0/30
+ sys-apps/file
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega || die
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}